Bug 4169

Summary: CheckpointListener clarification
Product: jbatch Reporter: mminella
Component: sourceAssignee: cvignola
Status: CLOSED FIXED    
Severity: normal CC: issues
Priority: P5    
Version: 1   
Target Milestone: ---   
Hardware: All   
OS: All   
Whiteboard:

Description mminella 2012-09-28 15:36:01 UTC
The CheckpointListener in the spec sounds like the methods are to be executed around the act of Checkpointing itself, instead of around the chunk of items.  Spring Batch's ChunkListener's beforeChunk is executed prior to any items being processed and afterChunk is executed once all of them within the chunk have been completed.
Comment 1 cvignola 2012-10-05 17:51:13 UTC
I think the issue is only terminology. We have a blending of WebSphere and Spring wording.  WebSphere uses the term "checkpoint" not only to cannote the actual act of writing the checkpoint, but also extends the term to refer to the items processed since the last time a checkpoint was taken. Hence checkpoint = chunk.  

I will look to clarify the language in the next spec draft.  

I am planning a flow diagram, which will help.
Comment 2 cvignola 2012-10-10 21:41:45 UTC
After further review, I realize there is a distinction between before/after chunk and before/after checkpoint.  

I revised the spec:

1) renamed CheckpointListener to ChunkListener
2) added beforeChunk/afterChunk method annotations
3) kept beforeCheckpoint/afterCheckpoint method annotations