Bug 2573 - Export names change size rapidly when mousing over highlighted objects
Export names change size rapidly when mousing over highlighted objects
Status: CLOSED FIXED
Product: electric
Classification: Unclassified
Component: GUI:Technology Editor
1
PC Linux
: P1 critical
: ---
Assigned To: developers
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-15 06:26 UTC by strubin
Modified: 2011-04-15 20:38 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description strubin 2011-04-15 06:26:37 UTC
** ORIGINALLY POSTED BY Frankie Liu on 2009-09-11 17:18:35 **

I cannot read export names on Export/Show Exports
It seems that there are two sets of things being written on top
of one another.

xprox/timingRecovery:inv100_50{lay}
Comment 1 strubin 2011-04-15 17:20:07 UTC
** ORIGINALLY POSTED BY Jonathan Gainsley on 2009-09-11 18:13:36 **

Try turning off the pulsating highlighting.
Prefs->Display->Display Control tab (or something similiar), uncheck enable pulsating highlights.
Comment 2 strubin 2011-04-15 17:20:10 UTC
** ORIGINALLY POSTED BY Adam Megacz on 2009-09-11 18:21:52 **

Working on it.
Comment 3 strubin 2011-04-15 17:20:12 UTC
** ORIGINALLY POSTED BY Adam Megacz on 2009-09-11 18:41:30 **

Fixed.
Comment 4 strubin 2011-04-15 17:20:15 UTC
** ORIGINALLY POSTED BY Frankie Liu on 2009-09-14 16:49:40 **

(In reply to comment #0)
> I cannot read export names on Export/Show Exports
> It seems that there are two sets of things being written on top
> of one another.
> 
> xprox/timingRecovery:inv100_50{lay}
> 

The pulsating highlighting is still illegible (sp?) for me.

This is for show exports.

Is there a way I can make that text larger, it defaults to some tiny size for me.
I can understand why Steve added the shadowing effect for this text so he doesn't have to worry about the user's background color, but the shadowing really makes this text hard to read, why not just allow change to the export text color like all the other display rendering colors.
Comment 5 strubin 2011-04-15 17:20:19 UTC
** ORIGINALLY POSTED BY Adam Megacz on 2009-09-15 01:00:56 **

> The pulsating highlighting is still illegible (sp?) for me.
> This is for show exports.

Are you sure you're running "soe -nightly" (I'm guessing not)?  If so, please take a screenshot and reopen the bug with the screenshot.
Comment 6 strubin 2011-04-15 17:20:21 UTC
** ORIGINALLY POSTED BY Gilda Garreton on 2009-09-17 12:56:04 **

I agree the export names are hard to read in the pulsing mode. Should actually those names pulse at all? The preference is described as for "error highlighting pulsate".
Comment 7 strubin 2011-04-15 17:20:24 UTC
** ORIGINALLY POSTED BY Gilda Garreton on 2009-09-18 16:15:12 **

Check the images in the usual place

1. /import/async/electric/bugzilla/data/bug2382/ExportNoPulsing.jpg (with errors pulsing off)

2. /import/async/electric/bugzilla/data/bug2382/ExportsWithPulsing.jpg (pulsing on)

Note that it is difficult to read in case 2. 

Is the text supposed to blink in this mode? you can sort of see that effect only if you move the mouse. Is that the effect we want?
Comment 8 strubin 2011-04-15 17:20:26 UTC
** ORIGINALLY POSTED BY Adam Megacz on 2009-09-19 11:54:30 **

Thank you for the screenshot Gilda!  Now I see what the problem is.  The size of the export names changes very rapidly, but ONLY when you mouse over something else that's highlighted AND you move the mouse.

I will fix this today.

Thanks again!

  - a
Comment 9 strubin 2011-04-15 17:20:28 UTC
** ORIGINALLY POSTED BY Gilda Garreton on 2009-09-24 14:22:42 **

Being released in v8.10i and verified. Closing now.