Bug 2653 - Null pointer exception while pasting layout cells.
Null pointer exception while pasting layout cells.
Status: CLOSED FIXED
Product: electric
Classification: Unclassified
Component: GUI:General
1
PC Linux
: P1 blocker
: ---
Assigned To: developers
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-15 06:30 UTC by strubin
Modified: 2011-04-15 20:42 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description strubin 2011-04-15 06:30:23 UTC
** ORIGINALLY POSTED BY Frankie Liu on 2009-11-09 10:21:07 **

open regselfbiasamp2{lay} from amp.delib in xnp paste cell from gategen library
stdtemp{lay}

This is not the only affected cells, it seems to be valid for other cell combinations as well.


java.lang.NullPointerException
\tat com.sun.electric.database.CellTree.with(CellTree.java:131)
\tat com.sun.electric.database.Snapshot.computeCellTrees(Snapshot.java:313)
\tat com.sun.electric.database.Snapshot.computeCellTrees(Snapshot.java:293)
\tat com.sun.electric.database.Snapshot.with(Snapshot.java:240)
\tat com.sun.electric.database.hierarchy.EDatabase.doBackup(EDatabase.java:483)
\tat com.sun.electric.database.hierarchy.EDatabase.backup(EDatabase.java:429)
\tat com.sun.electric.database.constraint.Layout.endBatch(Layout.java:179)
\tat com.sun.electric.tool.EThread.run(EThread.java:100)
Comment 1 strubin 2011-04-15 17:31:34 UTC
** ORIGINALLY POSTED BY Gilda Garreton on 2009-11-09 11:22:17 **

Dima

This error was generated with the latest version from SVN

Frankie and I haven't been able to reproduce this error but do you know why would subTree or techPool in CellTree.java:131?
Comment 2 strubin 2011-04-15 17:31:36 UTC
** ORIGINALLY POSTED BY nadezhin on 2009-11-09 11:37:56 **

Yes, I reproduced and fixed the bug:

FIX: In CellTree.with always continue cellUsages loop when cui == null.
Comment 3 strubin 2011-04-15 17:31:39 UTC
** ORIGINALLY POSTED BY Gilda Garreton on 2009-11-17 14:12:21 **


Being released in v8.10m and verified. Closing now.