Bug 4548 - Add onError to ChunkListener
Add onError to ChunkListener
Status: RESOLVED DUPLICATE of bug 4284
Product: jbatch
Classification: Unclassified
Component: source
1
All All
: P5 normal
: ---
Assigned To: cvignola
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-17 22:11 UTC by mminella
Modified: 2013-02-04 23:26 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mminella 2013-01-17 22:11:55 UTC
I know this interface was intended to mirror SB's.  SB recently added (it's in the nightly build) an afterChunkError method that is called once a chunk has been marked for rollback.  It handles the scenario where a chunk is rolled back (since afterChunk is not called in that scenario).
Comment 1 cvignola 2013-01-23 20:35:57 UTC
Will take into consideration.
Comment 2 ScottKurz 2013-02-04 20:24:26 UTC
Given where Bug 4284 has ended up, we could close this one 4548 as a dup I think.
Comment 3 cvignola 2013-02-04 23:26:24 UTC
But http://java.net/bugzilla/show_bug.cgi?id=4284 proposes to add onCommitError to ChunkListener, to be invoked if the transaction commit fails.  That's a narrow case resulting in rollback.  So let's call the method onError and invoke it in response to any condition that causes the rollback.

*** This bug has been marked as a duplicate of bug 4284 ***