Bugzilla – Bug 4549
Listener Error method naming consistency
Last modified: 2013-02-04 23:13:34 UTC
Some listener methods are named on*Exception (Job and Step for example) and others are on*Error (ItemRead and ItemWrite for example). We should standardize on one convention unless there is a reason that I can't see for the naming inconsistency.
on*Error will be the standard. StepListener.onException and JobListener.onException are being removed by http://java.net/bugzilla/show_bug.cgi?id=4284. All other methods conform to on*Error. So there is actually nothing further that needs to be done.