Bug 4561 - Parameters apply to a JobExecution
Parameters apply to a JobExecution
Status: RESOLVED DUPLICATE of bug 4562
Product: jbatch
Classification: Unclassified
Component: source
1
All All
: P5 major
: ---
Assigned To: cvignola
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-18 16:10 UTC by mminella
Modified: 2013-01-23 18:57 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mminella 2013-01-18 16:10:06 UTC
In section 7.8.10 on page 99, a method JobOperator#getParameters(JobInstance instance) is defined.  However, per the spec, job parameters are associated with a JobExecution, not an instance.  How does this work?
Comment 1 cvignola 2013-01-23 18:57:45 UTC
This bug is just a different perspective on the same issue raised in http://java.net/bugzilla/show_bug.cgi?id=4562

A little history: 

The public draft defined restart parameters and therefore parameters were per execution.

There was some uproar over restart parameters,  so it was removed in the proposed final draft. The parameters should have moved from JobExecution to JobInstance as part of that update, but did not.  That was an oversight. 

Let's allow resolution of Bug 4562 to determine whether or not the spec defines restart parameters and expect that resolution to also address the placement of getJobParameters() on JobExecution vs JobInstance.

*** This bug has been marked as a duplicate of bug 4562 ***