Bug 4710 - Consider clarifying that JobContext/StepContext may contain implementation-specific properties other than JSL properties.
Consider clarifying that JobContext/StepContext may contain implementation-sp...
Status: RESOLVED DUPLICATE of bug 5490
Product: jbatch
Classification: Unclassified
Component: SPEC
1
All All
: P5 minor
: ---
Assigned To: ScottKurz
1.0_mr_planned
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-23 02:48 UTC by mminella
Modified: 2014-01-07 18:54 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mminella 2013-02-23 02:48:28 UTC
1. testJobLevelPropertiesCount - This test implies that the JobContext.getProperites can *only* return properties configured and that properties object cannot be used by the runtime for anything else.  I'm not sure the spec is specific enough to rule that usage out (and would rather it not).
2. testJobLevelPropertiesPropertyValue - While this test is probably good enough, it would be nice to test the values for all three properties...
Comment 1 ScottKurz 2013-03-07 19:47:25 UTC
Chris,

Assigning this over to you for point #1 here... 

I think allowing runtime-specific properties in the JobContext and StepContext seems like a useful thing to do.   

On the other hand, it seems to me the most obvious reading of the current wording is that you get just what you see in the corresponding JSL, and so therefore testing for these and ONLY these properties is an appropriate TCK test.

I think to allow additional runtime-specific properties we should simply add language to the spec saying this is possible..then we'll go back and review the JobLevelPropertiesTests/StepLevelPropertiesTests test methods.
Comment 2 cvignola 2013-03-20 14:35:47 UTC
The runtime may insert properties in the JobContext and StepContext properties objects.  The spec does not say so, neither does it prohibit.  

I have asked Scott to revise the test case to not preclude runtime properties.
Comment 3 ScottKurz 2014-01-07 18:54:10 UTC
Resolve together with Bug 5490.

*** This bug has been marked as a duplicate of bug 5490 ***