Issue Details (XML | Word | Printable)

Key: ABOUT-61
Type: Task Task
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: sonyabarry
Reporter: fnikola
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
about

JCP Community on Java.net

Created: 24/May/11 09:15 AM   Updated: 09/Feb/12 11:18 PM   Resolved: 25/Jan/12 05:41 AM
Component/s: None
Affects Version/s: None
Fix Version/s: None

Time Tracking:
Original Estimate: Not Specified
Remaining Estimate: 0 minutes
Remaining Estimate - 0 minutes
Time Spent: 8 hours
Time Spent - 8 hours

Environment:

Java.net


Tags:
Participants: fnikola and sonyabarry


 Description  « Hide

this is a placeholder for all the initial steps to create the JCP Community on Java.net. For this task we are repurposing the JRP Community as JCP.

  1. The pmo project has been created and the jcp_pmo user has been given administrator rights
  2. Sonya is looking into why the jrs project returns the "Not Found" message and once resolved will update the project name to "jsrs"
  3. Sonya is compiling a list of the current jsr projects since some are less than 6 months old and after review the appropriate projects will be placed under the jsr-archive project
  4. Patrick will update the JCP Community introductory text at the top of the page (http://community.java.net/jcp)
  5. The outdated items have been removed from the page including the news in the right column and the community items from the feeds in the center main content area
  6. Update all JSR references to JCP


fnikola added a comment - 24/May/11 09:33 AM

from Patrick:

3. Good point. We should be careful about labeling as "archived" anything that's obviously still alive and active (such as the JavaServer Faces Specification project, for example.) We should probably discuss and reach agreement before moving anything.

4. I also noticed that once we get going we'll need to change some of the entries in the FAQ, since they say that there is no relationship between java.net and the JCP. That will no longer be (quite) true.

5. Looks much better now - thanks

The garbled text under Community Contacts is still there. '); // -->


fnikola added a comment - 24/May/11 09:35 AM - edited

from Patrick...

  1. There's no change on the redirect. http://jcp.java.net still points to the empty index page.
  2. The link to the jsr subproject from http://java.net/projects/jcp still gives a Not Found error. (We were going to change this to jsrs.) However, I'm wondering now whether there's any point to creating a hierarchy of projects and sub-projects since as far as I can tell any such hierarchy would not be visible to users. Am I missing something?
  3. Selecting JCP from the By Community tab on the master list of projects at http://www.java.net/projects leads to a page that still uses the name JSR and contains a link to View all JSR projects.
  4. Many of the projects listed on the master JCP project page (http://www.java.net/community/projects/jcp) contain links that lead to Not Found errors. See, for example, the Specification issues tracking for JSR235 link at the bottom of the first page. This project does actually exist (I could find it by searching) but it's private. Is this Not Found error therefore the result of a bug (should be Access Denied instead?) I thought there were only 19 projects that are part of the JCP community (that's how many show up in the list of projects by community at http://www.java.net/projects/community/143.) However, if the true number is much greater (as shown at http://www.java.net/community/projects/jcp) then maybe we shouldn't be trying to re-purpose this community at all?
  5. Whatever structure we end up with, I assume that if I create a project now I will be able to "move" it to a different community, make it a sub-project of another project that I own, etc?

fnikola added a comment - 24/May/11 09:41 AM

from Sonya...

1. Frank, can you try to set up a temporary redirect for this, and I'll nudge the Kenai team again on doing the permanent one?

2. It will be visible in the CMS and project catalog. I just added the jsrs project as a subproject to jcp, and made jcp_pmo the owner. Any new JSR that comes in should go there, and I'll sort through the older ones to let you know which I think should be archived and which should be moved into jsrs, (or another subproject if it's deemed necessary).

That not found error is a really weird bug. I saw this with a JUG project last week too. I just filed this with Kenai - http://kenai.com/jira/browse/KENAI-2892

3. Frank, can you give an ETA to update this?

4. I'll look into it a little more. Private projects shouldn't appear. I think some of them are that bug 2892 I just filed. I'll add more notes and/or file a different bug if it looks like a different issue.

We made the decision to go with a Not Found error for private projects because the access denied error gives a hacker a goal. The old Java.net site behaved this way as well.

The number is smaller - Frank is working on data cleanup across the site. Right now that list shows every project that was connected with JSR on the old site, but only a few of those were migrated, so the list will go to more 404s.

Frank, is there an ETA for that project?

The reason for repurposing this community is more political than practical - if we were to launch a new, separate JCP community, you'd have campaign for it, and get a vote from the other community leaders. It would be time consuming and I don't know how that would go - a lot of them are very down on Oracle (and they were upset with Sun too, this isn't a new dynamic) and would vote against another Oracle sponsored community (even if it is the JCP) just to be a pain. In the past they have voted down other Sun or Oracle sponsored projects, and when Sun essentially forced us to violate our own charter and stand them up anyway, it got really ugly.

Renaming the old community lets us skirt that process. Slightly slimy on my part? Yes. Corporate reality? That too.

5. If you own both, yes. If not it'll have to be done by me or Tonya for the next couple of months. Frank is working on building out the automated process that will let you do it yourself. We are aiming to launch that at J1 in October.


fnikola added a comment - 24/May/11 10:10 AM

1. I will need someone to set up an A record to point to our 209.189.227.38 server IP address

3. These changes have been completed.

4. The data cleanup should be completed by the end of the week.


fnikola added a comment - 27/May/11 05:26 AM

On May 26, 2011, at 3:35 PM, Patrick Curran wrote:

1. The Projects by Community: JCP page (http://www.java.net/projects/community/143) does not show my new jsr348 project. Why?

Also, how are is the "Featured Projects" list for our community (http://www.java.net/projects/#143) populated? The first two projects listed as "Featured" result in Access Denied error even though they claim to be public.

[Sonya] Both of these are related to the data cleanup Frank is doing. Once the old project data is purged, we're going to have to sync up the two databases. Right now the project is related to the jsrs project and the jcp community in the kenai database, but not yet in the drupal one. I'm hoping to get this all fixed early next week.

[Patrick] OK - if you let me know when that's complete I promise not to bug you about stuff like this until then

[Andrew] hi guys, just jumping in here on this issue. The featured projects page is hard-coded, we just choose three projects from each community to display on this page, and we haven’t updated it since the migration. If you have three in mind just send us the links and we’ll update that page.

[Sonya] Please let us know what projects you want to feature and we'll get those updated. Eventually this will be something you can do on your own as well.

[Patrick] Since the first two listed projects are "not found" (and probably obsolete) please add JSR348 as the first featured project and leave the JSP project as the second (it is active.)

2. While poking around with this I discovered what seems to be an anomaly. Frank had earlier reported "I changed the blog community taxonomy to JCP for the http://www.java.net/blogs/community/90 page."

On the assumption that the final portion of these URLs is a community ID why do we have two (143 and 90?) Is this perhaps the cause of the failure to be able to view the JSR project, which might have been the original "container" for the old community?

Or, maybe I'm just jumping to conclusions...

[Sonya] Frank can address this one.

[Patrick] OK - thanks...

[Frank] They are two different variables. The 143 is the internal community ID and the 90 is the taxonomy ID for the blogs.


fnikola added a comment - 03/Jun/11 12:13 PM - edited

The data cleanup has been completed with 4260 projects deleted include a few jrs projects.

All the remaining 19 jcp community projects exist on Kenai now.


fnikola added a comment - 25/Jan/12 05:41 AM

The JCP community has been implemented on java.net. Any further updates will require new enhancements.