adfemg
  1. adfemg
  2. ADFEMG-106

HrDemo111160_v1.2.zip : naming guidelines [ADFng2-04024], [ADFng1-03022], ...

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Labels:
      None

      Description

      hi

      The discussion topic "Shared: Basic Oracle HR Demo ADF BC application" [1] requests feedback on HrDemo111160_v1.2.zip [2].

      Maybe the application in HrDemo111160_v1.2.zip can be reviewed with the "ADF Naming and Project Layout Guidelines" [3] in mind.

      e.g. :

      • related to naming guideline

        [ADFng2-04024] - Java bean class name - Do not include the scope of a bean in its Java class file name.

        Although not in the class (file) name, HrDemo111160_v1.2.zip has class in a package that includes scope in its name:

        oracle.hrdemo.view.taskflows.depttaskflow.beans.pageFlowScope.pageFlowScope.depttaskflow
        

        Note also that class names typically start with an upper-case letter, so "depttaskflow" becomes "Depttaskflow", or maybe even "DeptTaskFlow" (related to naming guideline [ADFng1-01003]).
        Note also that package names typically are all lower-case (somewhat related to naming guideline [ADFng1-01002]).

      • related to naming guideline

        [ADFng1-03022] pageDef XML files for pages, page fragment or task flow data bounded method calls of the bounded task flow
        ViewController/adfmsrc/<default project package>/<boundedtaskflowname>

        For example, are these in the correct location ?

        HrDemo111160_v1.2\HrDemo\ViewController\adfmsrc\oracle\hrdemo\view\pageDefs\dept_task_flow_dept_task_flow_CreateInsertPageDef.xml
        HrDemo111160_v1.2\HrDemo\ViewController\adfmsrc\oracle\hrdemo\view\taskflows\depttaskflow\pageDefs\fragments\EditDepartmentsPageDef.xml
        HrDemo111160_v1.2\HrDemo\ViewController\adfmsrc\oracle\hrdemo\view\taskflows\depttaskflow\pageDefs\dept_task_flow_dept_task_flow_applyDepartmentIdViewCriteriaPageDef.xml

        Should there be "sub-packages" like "taskflows", "pageDefs" or "pageDefs.fragments", as intended by naming guideline [ADFng1-03022]?

      • related to naming guideline

        [ADFng1-03027] pageDef XML files for pages or task flow data bounded method calls of the unbounded task flow
        ViewController/adfmsrc/<default project package>

        For example, are these in the correct location ?

        HrDemo111160_v1.2\HrDemo\ViewController\adfmsrc\oracle\hrdemo\view\pageDefs\TestDeptTaskFlowPageDef.xml
        HrDemo111160_v1.2\HrDemo\ViewController\adfmsrc\oracle\hrdemo\view\pageDefs\TestEmpTaskFlowPageDef.xml

        Should there be a "sub-package" like "pageDefs", as intended by naming guideline [ADFng1-03027]?

      many thanks
      Jan Vervecken

        Activity

        chriscmuir added a comment -

        Agreed, the HR demo app could be reworked to match the guidelines (which were written later).

        As per ADFEMG-107 this has been on my to-do list for some time, but other work priorities keep on getting in the way. As such I'm going to mark this issue as "Wont fix" so I don't keep on double checking this issue while working through the ADF EMG issues. However hopefully in the future at some point I'll see the need to build a new version.

        CM.


          People

          • Assignee:
            Unassigned
            Reporter:
            Jan Vervecken
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: