adfemg
  1. adfemg
  2. ADFEMG-109

Character Disappers when using AutoTab property in group of InputTexts

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Labels:
      None
    • Environment:

      Jdev 11.1.1.6 , WLS 10.3.5

      Description

      Hi All ,
      I am trying to leverage the autoTab feature of ADF as in code below in a simple not data bound JSPX page

      <af:panelFormLayout id="pfl1" rows="1" maxColumns="3">
      <f:facet name="footer"/>
      <af:inputText id="inputText1" autoTab="true" maximumLength="3"/>
      <af:inputText id="inputText2" autoTab="true" maximumLength="2"/>
      <af:inputText id="inputText3" autoTab="true" maximumLength="4"/>
      </af:panelFormLayout>

      The issue that is happening on all browsers (IE,Mozilla, Chrome) is that the 3rd character I enter in the first Input Text disappers ! The tooltip when hovered over the 1st inputText does show the 3rd character though.
      I saw that this exact issue was already reported on forums long back -https://forums.oracle.com/forums/thread.jspa?threadID=2220395.

      Please let me know if someone knows a way t work this out without using custom JS or this indeed needs to be reported as a bug as Frank suggested in above post ?

      P.S. If I just have one inputText field this works fine , it happens only when I add a second one.

      Forum Post Link - https://forums.oracle.com/forums/thread.jspa?threadID=2501342

      Workspace - http://typical-adf-use-cases.googlecode.com/files/ForumsPOC.zip

      Reason Needed - Functionality in use at multiple places in our application.As a part of a Oracle Platinum Partner working at client site we are trying to prove capabilities of ADF over other frameworks.

        Activity

        Hide
        chriscmuir added a comment -

        Thanks for lodging. Issue verified. Bug 16384569 raised. Raise an SR is you need a fix to this issue.

        CM.

        Show
        chriscmuir added a comment - Thanks for lodging. Issue verified. Bug 16384569 raised. Raise an SR is you need a fix to this issue. CM.
        Hide
        sdesmukh added a comment -

        Thanks Chris . Can you please provide me a link where I can track the progress of the bug ?
        Also when you say I need to log an SR for the fix of this issue - DO you mean it might be backported to 11.1.1.6 ?

        Show
        sdesmukh added a comment - Thanks Chris . Can you please provide me a link where I can track the progress of the bug ? Also when you say I need to log an SR for the fix of this issue - DO you mean it might be backported to 11.1.1.6 ?
        Hide
        chriscmuir added a comment -

        You will need to log into My Oracle Support and query the bug number to find it.

        Regarding your last question, the point being this service does not provide an SLA. This implies we do not guarantee that the bug will be fixed by development nor can we kick off the patch generation mechanism. The only correct way is to lodge an SR with Oracle Support that you need a fix and then they will request development to see if it's feasible.

        CM.

        Show
        chriscmuir added a comment - You will need to log into My Oracle Support and query the bug number to find it. Regarding your last question, the point being this service does not provide an SLA. This implies we do not guarantee that the bug will be fixed by development nor can we kick off the patch generation mechanism. The only correct way is to lodge an SR with Oracle Support that you need a fix and then they will request development to see if it's feasible. CM.
        Hide
        chriscmuir added a comment -

        Fix scheduled 12.1.4.0.0.

        CM.

        Show
        chriscmuir added a comment - Fix scheduled 12.1.4.0.0. CM.
        Hide
        chriscmuir added a comment -

        Bug has been marked as not reproducible in the internal 12.1.3 build. I need to verify this.

        As advised previously if you require a fix for the 11gR1 branch you must lodge a SR with Oracle Support to have a fix created.

        CM.

        Show
        chriscmuir added a comment - Bug has been marked as not reproducible in the internal 12.1.3 build. I need to verify this. As advised previously if you require a fix for the 11gR1 branch you must lodge a SR with Oracle Support to have a fix created. CM.
        Hide
        chriscmuir added a comment -

        I can confirm this is not reproducible in an internal 12.1.3 build, and I'm closing this issue as a result. If the issue reoccurs on the public release of 12.1.3 then please reopen this issue.

        CM.

        Show
        chriscmuir added a comment - I can confirm this is not reproducible in an internal 12.1.3 build, and I'm closing this issue as a result. If the issue reoccurs on the public release of 12.1.3 then please reopen this issue. CM.

          People

          • Assignee:
            Unassigned
            Reporter:
            sdesmukh
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: