adfemg
  1. adfemg
  2. ADFEMG-114

ADF causing stuck threads in Weblogic Server

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Labels:
      None
    • Environment:

      ADF 11.1.1.4, Weblogic 10.3.4, any platform

    • Status Whiteboard:

      Oracle bug 10387411 and marked as fixed in 11.1.1.5.
      Patch 12312814 is available for 11.1.1.4.

      Show
      Oracle bug 10387411 and marked as fixed in 11.1.1.5. Patch 12312814 is available for 11.1.1.4.

      Description

      ADF application causes stuck threads in Weblogic. The thread dump will look similar to this:

      "[STUCK] ExecuteThread: '31' for queue: 'weblogic.kernel.Default (self-tuning)'" id=52 idx=0x10c tid=11850 prio=1 alive, waiting, native_blocked, daemon
         -- Waiting for notification on: oracle/adfinternal/controller/util/RequestLock@0x156aaab18[fat lock]
         at jrockit/vm/Threads.waitForNotifySignal(JLjava/lang/Object;)Z(Native Method)
         at jrockit/vm/Locks.wait(Locks.java:1973)[inlined]
         at java/lang/Object.wait(Object.java:485)[inlined]
         at oracle/adfinternal/controller/util/RequestLock.lock(RequestLock.java:42)[inlined]
         at oracle/adfinternal/controller/state/RootViewPortContextImpl.lockViewPortRequestLock(RootViewPortContextImpl.java:604)[optimized]
         ^-- Lock released while waiting: oracle/adfinternal/controller/util/RequestLock@0x156aaab18[fat lock]
        ...
      

      This is logged as Oracle bug 10387411 and marked as fixed in 11.1.1.5.

      Patch 12312814 is available for 11.1.1.4.

      More information is available in MOS note 1470757.1.

        Activity

        Kevin Angus created issue -
        Jan Vervecken added a comment -

        hi Kevin Angus

        The bug 10387411 you refer to currently does not seem to be published on My Oracle Support.

        Searching for bug 10387411 currently allows to find :

        • document id 1470757.1, "Slow Performance due to Stuck Threads: oracle/adfinternal/controller/util/RequestLock"
        • document id 1497156.1, "Is Patch 12312814 available for ADF 11.1.1.6"

        The "MOS note 1470757.1" you refer to currently says "Applies to: Oracle WebCenter Portal - Version 11.1.1.4.0 and later ..." and "Cause This is caused by an unpublished ADF bug.".
        You write "ADF application causes stuck threads in Weblogic.", but what makes you conclude that this is not "Oracle WebCenter Portal" specific?
        Can you be more specific about which ADF applications "cause stuck threads"?
        Do you know of a scenario to reproduce such "stuck threads"?

        thanks
        Jan Vervecken

        Kevin Angus added a comment -

        Hi Jan,

        Yes, sorry, the bug is not public, should have mentioned that.

        The Oracle support analyst that directed me to the note stated that I am hitting this bug so this is all I have based this on. There may be extra information in the bug that indicates this is relevant beyond WebCentre Portal.

        I have no idea what actually causes the stuck threads. I was seeing them apparently randomly on a production app and couldn't explain them so I contacted Oracle Support. They didn't provide a full explanation but I was happy to hear there was a bug/patch

        It was also the support analyst that stated the bug is fixed in 11.1.1.5 and I haven't noticed the problem on any 11.1.1.6 apps.

        Cheers,

        Kevin

        Jan Vervecken added a comment -

        Thank you for the update Kevin.

        regards
        Jan

        chriscmuir added a comment -

        As this issue is informational in nature as the bug and patch are already listed, can we look to close this issue please?

        CM.

        Kevin Angus made changes -
        Field Original Value New Value
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Kevin Angus
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: