adfemg
  1. adfemg
  2. ADFEMG-119

ViewAttribute IsUpdateable added when View Row class generated

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Labels:
      None

      Description

      hi

      Please consider the example application created using JDeveloper 11.1.1.6.0
      at http://www.consideringred.com/files/oracle/2013/Bug14689126NoRowInconsistentExceptionApp-v0.03.zip

      It allows to reproduce scenario (sc2) [1] :

      • (sc2-a) run the view "tryEmployeesVO" in JDeveloper, and open a second browser session
      • (sc2-b) in both browser sessions navigate to the same record (e.g. with "Email NKOCHHAR")
      • (sc2-c) in the first browser session change the value of the Email attribute (e.g. to "NKOCHHA1"), and click the Commit button, the changed should be applied in the database
      • (sc2-d) in the second browser session also change the value of the Email attribute (e.g. to "NKOCHHA2"), and click the Commit button, resulting in the message "Another user has changed the row with primary key oracle.jbo.Key[101 ]."

      It also allows to reproduce scenario (sc3) :

      • (sc3-a) Execute scenario (sc2), which results in the message "Another user has changed the row with primary key oracle.jbo.Key[101 ]." in step (sc2-d).
      • (sc3-b) Open the Source tab for EmployeesVO.xml and notice that the ViewAttribute element with Name="HireDate" does not have an IsUpdateable attribute.
      • (sc3-c) Open the Overview tab for EmployeesVO.xml and on the Java tab click the ("Edit java options") pencil button, in the Select Java Options dialog check the "Generate View Row Class: EmployeesVORowImpl" checkbox and click OK.
      • (sc3-d) Open the Source tab for EmployeesVO.xml again and notice that the ViewAttribute element with Name="HireDate" now has attribute IsUpdateable="false".
      • (sc3-e) Execute scenario (sc2), which now results in the message "Attribute HireDate in view object EmployeesVOVI cannot be set." in step (sc2-d).
      • (sc3-f) Open EmployeesVORowImpl.java and replace "extends ViewRowImpl" with "extends CustomerExtensionViewRowImpl" (which overrides setAttributeInternal() calling a throwIfAttrBeingSetIsModifiedOnAndValueDoesNotMatchDBValue() method).
      • (sc3-g) Execute scenario (sc2), which now again results in the message "Another user has changed the row with primary key oracle.jbo.Key[101 ]." in step (sc2-d).
      • (sc3-h) Open the Overview tab for EmployeesVO.xml again and on the Java tab click the ("Edit java options") pencil button, in the Select Java Options dialog uncheck the "Generate View Row Class: EmployeesVORowImpl" checkbox and click OK.
      • (sc3-i) Open the Source tab for EmployeesVO.xml again and notice that the ViewAttribute element with Name="HireDate" still has attribute IsUpdateable="false".
      • (sc3-j) Execute scenario (sc2), which now again results in the message "Attribute HireDate in view object EmployeesVOVI cannot be set." in step (sc2-d).

      If all of scenario (sc3) is intended behaviour, can someone please explain (e.g. the difference in steps (sc3-a) and (sc3-j), or why IsUpdateable="false" is added (but not removed)).
      If not intended behaviour, which Oracle bugs are relevant?

      many thanks
      Jan Vervecken

        Issue Links

          Activity

          Jan Vervecken added a comment -

          fyi

          About "Oracle resources", I have referred to this issue ADFEMG-119 in Oracle service request 3-6322025251.

          regards
          Jan Vervecken

          Jan Vervecken added a comment -

          fyi

          Just wanted to point out that if "-Djbo.ampool.doampooling=false" is removed from the run configuration (resulting in passivation/activation not to occur), scenario (sc3) also results in "Another user has changed the row with primary key oracle.jbo.Key[101 ]." for steps (sc3-e) and (sc3-j) (not in "Attribute HireDate in view object EmployeesVOVI cannot be set.").
          Which seems to lead back to the (different behaviour when passivation/activation occurs) subject of issue ADFEMG-62 (which Oracle currently considers as (unpublished) enhancement request 14651396 for which they don't know (if and) how it will be approached).

          regards
          Jan Vervecken

          Jan Vervecken added a comment -

          fyi

          Feedback in SR 3-6322025251 :
          "... created spin-off SR 3-7051033331 and raised Bug 16634101 ..."

          On My Oracle Support I have been able to find bug 16634101, "ISUPDATEABLE=FALSE ADDED ON VIEWATTRIBUTE WHEN ENTITYATTRIBUTE HAS HISTORYCOLUMN".

          regards
          Jan Vervecken

          chriscmuir added a comment -

          Jan, I'm looking through the SRs and bugs and I can see they've been marked as "not bugs" & I must admit looking through all the updates I'm a bit lost on is the current answer satisfactory or not. If you'd like me to pursue this further, can you summarize in a paragraph in English the base problem, then also summarize the current state of the issue & why it's not satisfactory.

          Thanks,

          CM.

          chriscmuir added a comment -

          No further info received, closing issue.

          CM.


            People

            • Assignee:
              Unassigned
              Reporter:
              Jan Vervecken
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: