adfemg
  1. adfemg
  2. ADFEMG-126

GlassFish Linux deployment, application server logs show many occurrences of "Exalogic optimization:oracle.jrf.UnknownPlatformException"

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Labels:
      None
    • Environment:

      ADF/JDeveloper 11.1.2.3, GlassFish 3.1.2.2, Linux (Oracle Enterprise)

    • Status Whiteboard:

      (via Oracle Support)

      Bug 14631409: ORACLE.JRF.UNKNOWNPLATFORMEXCEPTION: JRF IS UNABLE TO DETERMINE THE CURRENT APPL

      Fixed in 12.1.2.

      Patch available for 11.1.2.3.

      Show
      (via Oracle Support) Bug 14631409: ORACLE.JRF.UNKNOWNPLATFORMEXCEPTION: JRF IS UNABLE TO DETERMINE THE CURRENT APPL Fixed in 12.1.2. Patch available for 11.1.2.3.

      Description

      I deployed an ADF application to a GlassFish server on Linux.

      The application works fine but excessive logging was noticed on the app server.

      Many logs are created that look like this:

      [#|2013-03-27T11:59:51.274+0000|INFO|glassfish3.1.2|javax.enterprise.system.std.com.sun.enterprise.server.logging|_ThreadID=26;_ThreadName=Thread-4;|
      Error looking up JRF helper API to query Exalogic optimization:oracle.jrf.UnknownPlatformException: JRF is unable to determine the current application server platform.|#]
      

      I was seeing hundreds of these messages for even simple interactions with the application.

      Obviously this has space, I/O and CPU implications for the app server.

        Activity

        Kevin Angus added a comment -

        I have received the patch for 11.1.2.3 however it didn't fix the issue for me so I'm checking with support in case I didn't apply it correctly.

        I suspect though that some of the ADF Essentials libraries on GlassFish need to be updated but the patch documentation did not mention this. I'll see what support get back to me with.

        Regards,

        Kevin

        Jan Vervecken added a comment -

        fyi

        Searching for '14631409' on My Oracle Support resulted in finding patch 14631409.
        The patch 14631409 details page shows a section "Bugs Resolved by This Patch" with a link to bug 14631409, which currently results in an error page "Error 404 Not Found" when I click it.
        In SR 3-7153838921 I got confirmation that bug 14631409 is currently not published on My Oracle Support, and feedback that an error page "Error 404 Not Found" is "normal".

        regards
        Jan Vervecken

        shouvik.sayef added a comment -

        Hello,

        We have been experiencing the same issue. I had a few members of the team testing out our pages and one of our developers noticed that the memory usage for glassfish had jumped to about 64GB (It typically does not go over 5GB) and we had to restart our server. I attempted to look thorough the logs for the cause, and within a half hour period glassfish had produced ~25 full log files, each of which contained thousands of instances of this error (sometimes over a hundred per second). I am wondering if anyone else has had such severe memory usage issues, as it seems very excessive.

        Regardless I will look into patching JDeveloper and we will attempt to reproduce the error, and I may follow up here.

        chriscmuir added a comment -

        I note a backport was requested by a customer for 11.1.2.3.0. Shouvik, if that was you, can you advise and comment on the success of the backport.

        Alternatively if I don't hear from you, and as the bug appears to be fixed in 12.1.2, if I don't get a response in a week I'll close this issue.

        CM.

        chriscmuir added a comment -

        No comment back, issue closed.


          People

          • Assignee:
            Unassigned
            Reporter:
            Kevin Angus
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: