adfemg
  1. adfemg
  2. ADFEMG-137

IE 10 causing java.net.ProtocolException: EOF after reading only: '0' of: '16' promised bytes

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Labels:
      None

      Description

      hi

      When using Internet Explorer 10 on an ADF application, closing the browser window seems to cause a ProtocolException in WebLogic Server.

      Noticed this in different ADF applications,
      e.g. http://www.consideringred.com/files/oracle/2013/SessionUserDataNullApp-v0.01.zip (see also JIRA issue ADFEMG-136 )
      Using JDeveloper 11.1.2.4.0 with its integrated WebLogic Server 10.3.5.0 (running on Java version 1.6.0_24)

      This ProtocolException does not occur when using other browsers like Firefox or Google Chrome (when closing the browser window), only when using Internet Explorer 10.

      The JDeveloper log window shows

      weblogic.utils.NestedRuntimeException: Cannot parse POST parameters of request: '/SessionUserDataNullApp-ViewController-context-root/faces/tryEmployees'
      at weblogic.servlet.internal.ServletRequestImpl$RequestParameters.mergePostParams(ServletRequestImpl.java:2144)
      at weblogic.servlet.internal.ServletRequestImpl$RequestParameters.parseQueryParams(ServletRequestImpl.java:2024)
      at weblogic.servlet.internal.ServletRequestImpl$RequestParameters.getQueryParams(ServletRequestImpl.java:1918)
      at weblogic.servlet.internal.ServletRequestImpl$RequestParameters.getParameter(ServletRequestImpl.java:1995)
      at weblogic.servlet.internal.ServletRequestImpl$RequestParameters.access$800(ServletRequestImpl.java:1817)
      at weblogic.servlet.internal.ServletRequestImpl.getParameter(ServletRequestImpl.java:804)
      at javax.servlet.ServletRequestWrapper.getParameter(ServletRequestWrapper.java:169)
      at org.apache.myfaces.trinidadinternal.context.external.ServletRequestParameterMap.getAttribute(ServletRequestParameterMap.java:43)
      at org.apache.myfaces.trinidadinternal.context.external.ServletRequestParameterMap.getAttribute(ServletRequestParameterMap.java:31)
      at org.apache.myfaces.trinidadinternal.context.external.AbstractAttributeMap.get(AbstractAttributeMap.java:73)
      at oracle.adfinternal.controller.state.ControllerState.getRootViewPortFromRequest(ControllerState.java:788)
      at oracle.adfinternal.controller.state.AdfcContext.initialize(AdfcContext.java:185)
      at oracle.adfinternal.controller.state.AdfcContext.initialize(AdfcContext.java:79)
      at oracle.adfinternal.controller.application.AdfcConfigurator.beginRequest(AdfcConfigurator.java:53)
      at org.apache.myfaces.trinidadinternal.config.GlobalConfiguratorImpl._startConfiguratorServiceRequest(GlobalConfiguratorImpl.java:562)
      at org.apache.myfaces.trinidadinternal.config.GlobalConfiguratorImpl.beginRequest(GlobalConfiguratorImpl.java:212)
      at org.apache.myfaces.trinidadinternal.webapp.TrinidadFilterImpl.doFilter(TrinidadFilterImpl.java:174)
      at org.apache.myfaces.trinidad.webapp.TrinidadFilter.doFilter(TrinidadFilter.java:92)
      at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56)
      at oracle.security.jps.ee.http.JpsAbsFilter$1.run(JpsAbsFilter.java:119)
      at java.security.AccessController.doPrivileged(Native Method)
      at oracle.security.jps.util.JpsSubject.doAsPrivileged(JpsSubject.java:315)
      at oracle.security.jps.ee.util.JpsPlatformUtil.runJaasMode(JpsPlatformUtil.java:442)
      at oracle.security.jps.ee.http.JpsAbsFilter.runJaasMode(JpsAbsFilter.java:103)
      at oracle.security.jps.ee.http.JpsAbsFilter.doFilter(JpsAbsFilter.java:171)
      at oracle.security.jps.ee.http.JpsFilter.doFilter(JpsFilter.java:71)
      at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56)
      at oracle.dms.servlet.DMSServletFilter.doFilter(DMSServletFilter.java:139)
      at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56)
      at weblogic.servlet.internal.RequestEventsFilter.doFilter(RequestEventsFilter.java:27)
      at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56)
      at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.wrapRun(WebAppServletContext.java:3715)
      at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:3681)
      at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
      at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:120)
      at weblogic.servlet.internal.WebAppServletContext.securedExecute(WebAppServletContext.java:2277)
      at weblogic.servlet.internal.WebAppServletContext.execute(WebAppServletContext.java:2183)
      at weblogic.servlet.internal.ServletRequestImpl.run(ServletRequestImpl.java:1454)
      at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209)
      at weblogic.work.ExecuteThread.run(ExecuteThread.java:178)
      Caused by: java.net.ProtocolException: EOF after reading only: '0' of: '16' promised bytes, out of which at least: '0' were already buffered
      at weblogic.servlet.internal.PostInputStream.complain(PostInputStream.java:93)
      at weblogic.servlet.internal.PostInputStream.read(PostInputStream.java:179)
      at weblogic.servlet.internal.ServletInputStreamImpl.read(ServletInputStreamImpl.java:228)
      at weblogic.servlet.internal.ServletRequestImpl$RequestParameters.mergePostParams(ServletRequestImpl.java:2118)
      ... 39 more

      Can this ProtocolException be reproduced?
      Is this ProtocolException intended behaviour?

      many thanks
      Jan Vervecken

        Activity

        Jan Vervecken added a comment -

        Created Oracle service request 3-7306013581 for this JIRA issue ADFEMG-137 .

        Jan Vervecken added a comment -

        fyi

        Feedback from the support engineer in SR 3-7306013581 :
        "I have replicated the issue with JDeveloper 11.1.2.3 on IE 10."

        regards
        Jan Vervecken

        Jan Vervecken added a comment -

        fyi

        Feedback from the support engineer in SR 3-7306013581 :

        • "... I have filed a Bug 16910232 ..."
          • I have been able to find bug 16910232, "IE 10 CAUSING JAVA.NET.PROTOCOLEXCEPTION", on My Oracle Support.

        regards
        Jan Vervecken

        Jan Vervecken added a comment -

        fyi

        Feedback in SR 3-7306013581 :

        • "... The BDE has updated that, the issue is not seen in the later version but what changed in the later version was not identified. ..."
          • bug 16910232 currently has "Fixed in Product Version 12.1.2.0.0"
        • when asked
          How can the frequent and large stack-traces for the weblogic.utils.NestedRuntimeException/java.net.ProtocolException (bug 16910232) in the WebLogic Server log files be avoided?
          • "... We cannot filter the logging of exception is log. ..."

        regards
        Jan Vervecken

        chriscmuir added a comment -

        Jan, as this bug is marked as fixed in 12.1.2.0.0, from the ADF EMG issue tracker perspective please close the issue.

        CM.

        chriscmuir added a comment -

        No further info received, closing issue.

        CM.


          People

          • Assignee:
            Unassigned
            Reporter:
            Jan Vervecken
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: