adfemg
  1. adfemg
  2. ADFEMG-13

JDeveloper 11.1.2.1.0 don't show correct query in ViewCriteria editor

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Labels:
      None
    • Environment:

      Win7 64Bit, JDK 1.6.0, JDev 11.1.2.1.0

      Description

      JDeveloper version : 11.1.2.1.0
      WebLogic Server version : 10.3.5 with patches
      impact level : low
      why : annoying
      summary :
      JDeveloper don't show the correct query or where clause in the ViewCriteria editor when defining or editing a ViewCriteria for a ViewObject.
      When you create a new criteria both check boxes 'Ignore Case' and 'Ignore NULL Values' are checked (for applicable attributes). However, the 'View Object Where Clause' omits the parts of the where clause once you close the dialog and open it again.
      The where clause of a typical ViewCriteria with 'Ignore Case' should read like
      (UPPER(Employees.LAST_NAME) LIKE UPPER( :bindLN || '%') )
      but reads
      ((Employees.LAST_NAME LIKE (:bindLN || '%'))

      The query is executed with the missing where clause parts!

      This is running in 11.1.1.4.0 and 11.1.1.6.0 (did not check 11.1.1.5.0).
      (See also my blog http://tompeez.wordpress.com/2012/04/05/jdeveloper-case-insensitive-search-and-performance/)

        Activity

        Timo_Hahn added a comment -

        SR 3-5553881391 opened for this bug

        Timo_Hahn added a comment -

        As a result of the SR
        Bug 13932370 : CASE INSENSITIVE VIEW CRITERIA DOES NOT GENERATE CORRECT QUERY
        has been created

        chriscmuir added a comment -

        Confirmed bug submitted. Not yet triaged by internal support (and not expecting so immediately over Easter break ... give it a few more days).

        fnimphiu added a comment -

        I see the bug being reproduced with internal builds of 11g R2 as well, So there is progress on this. Seems that 12c builds don't have this problem.

        Jan Vervecken added a comment -

        hi Timo

        Just wanted to confirm some aspects of the issue you describe.
        Whatever the value for the Ignore Case checkbox, the UPPER() function is not shown in the where clause at design-time.
        At run-time however this seems to behave as configured.
        see also the screencast at http://screencast.com/t/wO9XozqbNdZ

        regards
        Jan Vervecken

        Jan Vervecken added a comment -

        I wonder why bug 13932370 got "Status 35 - To Filer for Review" yesterday (May 4, 2012)?

        Timo_Hahn added a comment -

        Thanks for pointing this out Jan, looks like support has put a fix version number (12.1.2) on this issue. That, I guess, is the reason for the status change.
        I've not heard from support officially on this and don't expect so as the SR its closed already.
        May be Chris or Frank can shed some light on this.

        chriscmuir added a comment -

        As copied straight from the internal bug:

        @ This functionality works as expected on the MAIN branch, but is verified as
        @ incorrect on the 11.1.2 branch. Also works ok on 11.1.1.* series. If you
        @ need this fixed for 11.1.2.3.0 (has not been scheduled yet) please file a
        @ backport request.

        Ah, the fun of having 3 branches of JDev. As such it's as Frank says, the issue is in the 11.1.2.X branch but should be absent from 11.1.1.6.0+ and the eventual 12c branch. If a fix is critical please lodge a backport request.

        At this time as this is the equivalent of a scheduled fix (12c) I believe we can just sit on this one and wait.

        CM.

        Timo_Hahn added a comment -

        Thanks for the update Chris.
        Now you only have to reveal the release date for 12c to make us all happy

        chriscmuir added a comment -

        I've confirmed this issue has been resolved in an internal 12c build. I'll close this issue at this time so I don't have to keep on tracking it. However if the problem returns please reopen the issue.


          People

          • Assignee:
            Unassigned
            Reporter:
            Timo_Hahn
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: