adfemg
  1. adfemg
  2. ADFEMG-20

ListOfValuesModelImpl : No row found for rowKey

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Labels:
      None

      Description

      hi

      • JDeveloper version : 11.1.2.1.0
      • WebLogic Server version : n.a.
      • impact level : ?
      • summary :
        The first time a specific value entered in an af:inputListOfValues component is accepted, a second time it gets replaced with a previous value.
      • testcase :
        see TestLOVAutoSuggest.rar available in ADFEMG-14
        at http://java.net/jira/secure/attachment/49659/TestLOVAutoSuggest.rar
      • steps to reproduce :
        The following scenario (sc1) describes how to reproduce the behaviour using TestLOVAutoSuggest.rar
        • (sc1-a) open TestLOVAutoSuggest.jws in JDeveloper 11.1.2.1.0
        • (sc1-b) configure a valid HR connection
        • (sc1-c) run TestPage.jspx
        • (sc1-d) in the DepartmentId field type "30" and press tab (where "30" is a valid value and the only one starting with "30"), notice that the value remains and no LOV dialog appears
        • (sc1-e) in the DepartmentId field type "10" and press tab (where "10" is the prefix of more than one valid value)
        • (sc1-f) in the LOV dialog select a valid value
        • (sc1-g) in the DepartmentId field type "30" (again) and press tab (where "30" is the same value as in step (sc1-d)), notice that the value does not remain and gets replaced by the value selected in step (sc1-f),
          also notice the "IntegratedWegLogicServer - Log" panel in JDeveloper has a message like:
          <FacesCtrlLOVBinding$ListOfValuesModelImpl> <getValueFromSelection> ADFv: No row found for rowKey: oracle.jbo.Key[30 ].
          
      • occured result/behaviour :
        a "No row found for rowKey" message for a value that was "found" before
      • expected result/behaviour :
        have step (sc1-g) behave the same as (sc1-d), so that a valid value remains
      • (q1) Can the behaviour in scenario (sc1) be reproduced?
      • (q2) Is the behaviour in step (sc1-g) intended behaviour?

      many thanks
      Jan Vervecken

        Activity

        chriscmuir added a comment -

        Bugged has been escalated to priority 2.

        CM.

        chriscmuir added a comment -

        Still progressing internally.

        CM.

        chriscmuir added a comment -

        Reportedly fixed in 12.1.2. Need to wait for release and verify.

        chriscmuir added a comment -

        Verified fix in 12.1.2 and I don't see the message in the logs any longer. Jan, could you verify please and close the EMG issue if you're happy with the result.

        CM.

        chriscmuir added a comment -

        GIven there was no update I assume the issue has been resolved. Closing issue.

        CM.


          People

          • Assignee:
            Unassigned
            Reporter:
            Jan Vervecken
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: