adfemg
  1. adfemg
  2. ADFEMG-31

Focus is Lost in IE8 when value is changed in Input List of values

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Incomplete
    • Labels:
      None

      Description

      Jdeveloper 11.1.1.6 version. It was not reproduced in 11.1.1.4.

      When a value is selected or typed in an Input List Of values then the focus (cursor) goes to the internet explorer tab. This causes frustration to user's and delay in data entry.

      steps to reproduce:
      In the attached test case run TestLov.jspx in Internet Explorer 8.
      1. Click on magnifier icon of DepartmentId
      2. Select a department and click Ok button.
      Focus is lost from the field. (if you press tab you see it is on the first component of the page)

      The same is reproduced if you click inside departmentId field and type an different valid value and press tab.
      Focus goes back to the Internet explorer tab page.

      This issue does not reproduce in Firefox since Focus remain in departmentId field.

      SR 3-5826491671

        Activity

        KoenVerhulst added a comment -

        Is it possible to reopen this issue?
        We are facing the same problem, which also causes "frustration to users and delay in data entry".

        chriscmuir added a comment -

        Please open an SR with Support, reference the bug number, and let us know the SR number.

        steven.davelaar added a comment -

        There are quite a few known bugs related to loosing focus:

        Bug 14191430 - FOCUS LOST IN IE8 WHEN VALUE IS CHANGED IN INPUT LIST OF VALUES
        Bug 12905230 - CURSOR LOOSES FOCUS WHEN TABBING IN IE8
        Bug 13518300 - ADF TABLE LOSES FOCUS IN INTERNET EXPLORER 8 AND 9
        Bug 13397220 - CURSOR LOOSES FOCUS AFTER PRESSING <TAB> IN TABLE WITH AUTOSUBMIT=TRUE
        Bug 12905230 - CURSOR LOOSES FOCUS WHEN TABBING IN IE8

        Looks like you are running into bug 14191430

        KoenVerhulst added a comment -

        Thanks for your reply Steven.

        I created SR 3-6518516151 for this issue.

        KoenVerhulst added a comment -

        There seems to be a (working workaround for the issue "Focus lost in IE8 when value is changed".
        See note 1495793.1


          People

          • Assignee:
            Unassigned
            Reporter:
            mkoniotakis
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: