adfemg
  1. adfemg
  2. ADFEMG-36

enhancement request for a public API for FacesCtrlLOVBinding

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Works as designed
    • Labels:
      None

      Description

      hi

      Please consider the blog post by Frank Nimphius, "How-to dynamically filter model-driven LOV"
      at https://blogs.oracle.com/jdevotnharvest/entry/how_to_dynamically_filter_model

      It says : "... Note: There is no public API yet available for the FacesCtrlLOVBinding class, which is why I use the internal package class it in the example. ..."

      Which seems to be referring to oracle.adfinternal.view.faces.model.binding.FacesCtrlLOVBinding .

      • (q1) Has an enhancement request for a public API for FacesCtrlLOVBinding been created?

      many thanks
      Jan Vervecken

        Issue Links

          Activity

          duncanmills added a comment -

          The correct usage in this case should be to cast to oracle.jbo.uicli.binding.JUCtrlListBinding. You then have access to the getListIterBinding() function to return the iterator and so in.

          duncanmills added a comment -

          Oh and I've asked Frank to amend the blog entry

          duncanmills added a comment -

          See correct API as above

          Jan Vervecken added a comment -

          Thanks for your replies Duncan.

          In the example application
          at http://www.consideringred.com/files/oracle/2012/DynamicallyFilterMDLOVApp-v0.01.zip
          that I refer to in the forum thread "dynamically filter model-driven LOV : search-values visible"
          at https://forums.oracle.com/forums/thread.jspa?threadID=2419959
          I have applied your suggestion, using JUCtrlListBinding instead of FacesCtrlLOVBinding.

          It looks like Frank's blog post has also been updated.

          regards
          Jan Vervecken

          Jan Vervecken added a comment -

          about the same blog post

          Jan Vervecken added a comment -

          related to ADFEMG-38, about the same blog post


            People

            • Assignee:
              duncanmills
              Reporter:
              Jan Vervecken
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: