adfemg
  1. adfemg
  2. ADFEMG-38

oracle.jbo.ViewCriteria.addRow() : For internal use only.

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Labels:
      None

      Description

      hi

      Please consider the blog post by Frank Nimphius, "How-to dynamically filter model-driven LOV"
      at https://blogs.oracle.com/jdevotnharvest/entry/how_to_dynamically_filter_model

      Its sample code suggests to call oracle.jbo.ViewCriteria.addRow() for which the method documentation says
      "For internal use only."
      at http://docs.oracle.com/cd/E23943_01/apirefs.1111/e10653/oracle/jbo/ViewCriteria.html#addRow%28oracle.jbo.ViewCriteriaRow%29

      • (q1) Is there an alternative/equivalent API that is not "For internal use only."?

      many thanks
      Jan Vervecken

        Issue Links

          Activity

          duncanmills added a comment -

          Please check the 11.1.1.6 version of the docs and you'll find your answer:
          http://docs.oracle.com/cd/E23943_01/apirefs.1111/e10653/oracle/jbo/ViewCriteria.html#addRow(oracle.jbo.ViewCriteriaRow)
          Use add() instead.

          In general I don't think this system is a good place to report issues with random blog articles - it's better to follow up with the writer of the article directly

          Jan Vervecken added a comment -

          Thanks for your reply Duncan.

          • about "Please check the 11.1.1.6 version of the docs and you'll find your answer: ... Use add() instead."
            • I missed the example at the beginning of the ViewCriteria class documentation.
          • about "In general I don't think this system is a good place to report issues with random blog articles ..."
            • The blog reference was not random, it was intended to provide a specific context (a use-case) for why/where the method was used, and an alternative/equivalent API that is not "For internal use only." would be preferred.

          regards
          Jan Vervecken


            People

            • Assignee:
              Unassigned
              Reporter:
              Jan Vervecken
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: