adfemg
  1. adfemg
  2. ADFEMG-46

confusing documentation jbo.locking.mode default

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Labels:
      None

      Description

      hi

      Please consider Oracle® Fusion Middleware Fusion Developer's Guide for Oracle Application Development Framework 11g Release 1 (11.1.1.6.0) Part Number B31974-11.

      It has some confusing documentation about the jbo.locking.mode default value.

      When I create an Application Module using JDeveloper 11.1.1.6.0 its configuration shows a jbo.locking.mode property value of "optimistic" with the comment "The locking mode is overridden by adf-config.xml".
      In adf-config.xml I found

      <amconfig-overrides>
        <config:Database jbo.locking.mode="optimistic"/>
      </amconfig-overrides>
      
      • (q1) What is the jbo.locking.mode default value (maybe for different JDeveloper versions)?
      • (q2) Should a documentation bug be created for the jbo.locking.mode default in B31974-11 ?

      many thanks
      Jan Vervecken

        Activity

        Jan Vervecken added a comment - - edited

        fyi

        Today I noticed a recent update in bug 14535422:

        *** 09/04/12 05:09 pm *** (CHG: Sta->89)
        *** 09/04/12 05:09 pm ***
        Corrections to the ADF Dev Guide appear in all branches of the ADF Dev Guide 
        (11gR1, 11gR2, and 12c). The above sections have been reworded so the default 
        value for jbo.locking.mode is stated as "optimistic".
         
        Currently, the only version that has been published to OTN with these 
        corrections is in 11.1.2.3.0 (11gR2). All other releases are pending, but the 
        corrections are visible in internal documentation builds.
        

        (with "Status 89 - Tech Writer to Q/A")

        regards
        Jan Vervecken

        chriscmuir added a comment -

        Documentation internally sits in a drafting area, and then is moved to an unpublished area inside OTN that external customers can't see.

        CM.

        Jan Vervecken added a comment -

        fyi

        The status of bug 14540301 has changed to "Status 80 - Development to Q/A" and it also says "Fixed in Product Version 12.1.2.0.0".

        *** 09/14/12 11:56 am ***
        *** 09/14/12 11:58 am ***
        RELEASE NOTES:
        ]]Locking mode has been removed from the AM inspector page reached from bc4j.cf
        ]]g
         
        REDISCOVERY INFORMATION:
        Lcking mode is being displayed in AM inspector page reached from bc4j.cfg
        Farm run 8161657
        WORKAROUND:
        None
        *** 09/14/12 12:02 pm *** 
        *** 09/14/12 12:02 pm *** (CHG: Sta->80)
        *** 09/15/12 12:12 pm ***
        *** 09/15/12 06:21 pm ***
        

        regards
        Jan Vervecken

        chriscmuir added a comment -

        This fix is confirmed in the 11.1.2.3.0 public documentation set and the 12.1.2 yet to be published document set. Issue closed, reopen if necessary.

        Jan Vervecken added a comment -

        Thank you for the update Chris.

        regards
        Jan Vervecken


          People

          • Assignee:
            Unassigned
            Reporter:
            Jan Vervecken
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: