Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Labels:
      None
    • Environment:

      JDeveloper 11.1.1.6.0

      Description

      There is no context menu "Refactor" available to move a pagedefinition to another location. Today I was struggling to simply move a pagedefinition to another package. It seems that the "move" functionality needs to be executed from the menubar Refactor > Move.

      It would make sense to add the "Refactor" menu (and its possible submenu items) to the context menu.

      (Seems like this is related with bug 7502373, marked as "not a bug")

        Activity

        Jan Vervecken added a comment -

        hi Koen

        It sounds like a reasonable suggestion to have a refactor move option in the context-menu of a Page Definition file.

        Also because Page Definition files can end up "all over the place", see the related JIRA issue ADFEMG-63 .

        regards
        Jan Vervecken

        chriscmuir added a comment -

        This issue doesn't appear to be specific to pageDef files, but rather XML files in general within the ViewController project. Agree?

        KoenVerhulst added a comment -

        I agree it should be available for XML files in general. Although most of the time it will be used to refactor page definition files, since this requires an update in the databindings.cpx.

        Refactoring more than 1 page definition file at a time would also make sense. Moving pageDefs 1 by 1 is quite hard. Certainly because pageDefs files can end all over the place (see http://java.net/jira/browse/ADFEMG-63).

        duncanmills added a comment -

        Just to rein this in a little. PageDefs are very different from Java Files. We have refactor on move capabilities for Java files because moving a single file can result in updates to multiple dependent files and it might be easy to miss one.
        PageDefs have the opposite scenario. Moving any number of pageDef files only ever requires an update to at most two files, the cpx and the jazn-data. So it's not really a pain to do in bulk from the o/s if required.
        Nevertheless this issue is known and the refactoring of xml files on the context menu is present in 12c builds


          People

          • Assignee:
            duncanmills
            Reporter:
            KoenVerhulst
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: