adfemg
  1. adfemg
  2. ADFEMG-62

Bug 14689126 : NO ROWINCONSISTENCYEXCEPTION RAISED WHEN AM POOLING IS TURNED OFF

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Labels:
      None

      Description

      hi

      Please consider the example application created using JDeveloper 11.1.1.6.0
      at http://www.consideringred.com/files/oracle/2012/Bug14689126NoRowInconsistentExceptionApp-v0.01.zip

      Note that it has "-Djbo.ampool.doampooling=false" configured.

      It should allow to reproduce this scenario (sc1):

      • (sc1-a) run the view "tryEmployeesVO" in JDeveloper, and open a second browser session
      • (sc1-b) in both browser sessions navigate to the same record (e.g. with "Email NKOCHHAR")
      • (sc1-c) in the first browser session change the value of the Email attribute (e.g. to "NKOCHHA1"), and click the Commit button, the change should be applied in the database
      • (sc1-d) in the second browser session also change the value of the Email attribute (e.g. to "NKOCHHA2"), and click the Commit button, the change is applied in the database without an error message

      see also the screencast at http://screencast.com/t/r17bTFhfPdLk

      With Application Module pooling, a similar scenario results for step (sc1-d) in
      oracle.jbo.RowInconsistentException: JBO-25014: Another user has changed the row with primary key oracle.jbo.Key[101 ].

      see also the screencast at http://screencast.com/t/sW3p7MPO8s

      This behaviour seems to match
      Bug 14689126 : NO ROWINCONSISTENCYEXCEPTION RAISED WHEN AM POOLING IS TURNED OFF
      which currently has "Product Version 11.1.2.1.0" and "Severity 2 - Severe Loss of Service"

      • (q1) Does the behaviour in scenario (sc1) match bug 14689126 ?
      • (q2) Should the Product Version attribute from bug 14689126 be updated from 11.1.2.1.0 to 11.1.1.6.0 ?

      many thanks
      Jan Vervecken

        Issue Links

          Activity

          chriscmuir added a comment -

          Hi Jan, not sure why you cross posted, I'll continue to follow up here.

          In regards to your question "So, some database tables will have to be modified to include a change-indicator column, if a robust ADF application is to be built. Just wondering if my interpretation is correct, if not maybe someone can explain where I have misunderstood?"

          Yes, I believe your interpretation is correct.

          As before please continue to pursue the SR and relating bug through Oracle Support.

          Thanks,

          CM.

          Jan Vervecken added a comment -

          Thank you for the update Chris.

          • about "... not sure why you cross posted ..."
            • Because it could be considerd a "different issue" :
              • in 11g : a bug (14774050), undocumented behaviour
              • in 12g : intended, documented behaviour
          • about "... Yes, I believe your interpretation is correct. ..."
            • Thank you for the confirmation.

          regards
          Jan Vervecken

          chriscmuir added a comment -

          This issue doesn't appear to have any work to be done/tracked from the EMG issue tracker perspective. Can it be closed? Will do so on next revisit.

          CM.

          chriscmuir added a comment -

          As per last comment.

          CM.

          Jan Vervecken added a comment -

          fyi

          related to JIRA issue ADFEMG-151, "ADF Code Guidelines - include new change indicator mandatory recommendation?"

          regards
          Jan Vervecken


            People

            • Assignee:
              Unassigned
              Reporter:
              Jan Vervecken
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: