adfemg
  1. adfemg
  2. ADFEMG-67

ADF Mobile : pageFlowScope managed-bean in bounded task-flow

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Labels:
      None

      Description

      hi

      Please consider the example application created using JDeveloper 11.1.2.3.0
      at http://www.consideringred.com/files/oracle/2012/NavigationTimeMApp-v0.01.zip
      and as APK at http://www.consideringred.com/files/oracle/2012/navigationtimemapp-v0.01.apk

      It allows for the following scenario (sc1):

      • (sc1-a) start the app
      • (sc1-b) click the "do goSecondView using pf_TimerBean" button, which will navigate to "secondView" showing something like "no timer info yet"
      • (sc1-c) click the "do goFirstView using pf_TimerBean" button, which will navigate to "firstView" showing something like "no timer info yet"
      • (sc1-d) if you care to stop the app, try a "Force stop" on the "App info" via "Apps" in the Android settings

      And also scenario (sc2):

      • (sc2-a) start the app
      • (sc2-b) click the "do goSecondView using a_TimerBean" button, which will navigate to "secondView" showing something like "timer started 621 milliseconds ago"
      • (sc2-c) click the "do goFirstView using a_TimerBean" button, which will navigate to "firstView" showing something like "timer started 537 milliseconds ago"
      • (sc2-d) if you care to stop the app, try a "Force stop" on the "App info" via "Apps" in the Android settings

      The page firstView.amx has these components (and similar in secondView.amx):

      <amx:outputText value="pf_TimerBean : #{pageFlowScope.pf_TimerBean.timerInfo}" id="ot2"/>
      <amx:commandButton text="do goSecondView using pf_TimerBean" id="cb1" action="goSecondView"
                     actionListener="#{pageFlowScope.pf_TimerBean.startTimer}"/>
      <amx:outputText value="a_TimerBean : #{a_TimerBean.timerInfo}" id="ot3"/>
      <amx:commandButton text="do goSecondView using a_TimerBean" id="cb2" action="goSecondView"
                     actionListener="#{a_TimerBean.startTimer}"/>
      

      It looks like the managed-bean #

      {pageFlowScope.pf_TimerBean}

      is not shared between the pages/views in the bounded task-flow.

      • (q1) Why does scenario (sc1) not behave similar to scenario (sc2) (allowing to measure time by accessing the same managed-bean instance on both pages/views)?

      many thanks
      Jan Vervecken

        Activity

        Jan Vervecken added a comment -

        fyi

        My e-mail to Joe Huang, referring to this JIRA issue ADFEMG-67, did not result in any feedback.

        I created service request 3-6412035501 for this.

        regards
        Jan Vervecken

        Jan Vervecken added a comment -

        fyi

        In service request 3-6412035501 I got this feedback:
        "... I have been able to make your mobile application work by revising the two view definitions by changing [ pageFlowScope.pf_TimerBean ] to [ pf_TimerBean ] ..."

        I have added amx:outputText and amx:commandButton components using "pf_TimerBean" (instead of "pageFlowScope.pf_TimerBean") EL expressions on both firstView.amx and secondView.amx as you suggested.
        (see http://www.consideringred.com/files/oracle/2012/NavigationTimeMApp-v0.04.zip
        and as APK at http://www.consideringred.com/files/oracle/2012/navigationtimemapp-v0.04.apk )
        Yes, these changes seem to allow behaviour similar to scenario (sc2), but it doesn't really answer question (q1).

        When the "pageFlowScope" scope-prefix is not used in EL expression, the AMX file editor in JDeveloper shows warnings like 'Reference "pf_TimerBean" not found'.
        Using the "Edit Property: Action Listener" to configure the Action Listener property automatically results in an EL expression that uses the "pageFlowScope" scope-prefix.

        All this suggests something is wrong in scenario (sc1).

        • (q2) Can a bug be filed for the bounded task-flow managed-bean with scope pageFlow behaviour in scenario (sc1)?

        (Note that I have made some additional changes in NavigationTimeMApp-v0.04.zip intended to show object instance information for the TimerBean, but that results in some strange information shown on the AMX views for which I have not found time yet to look into.)

        regards
        Jan Vervecken

        Jan Vervecken added a comment - - edited

        fyi

        • about (q2)
          • in the context of SR 3-6412035501 bug 15989335, "AMX:COMMANDBUTTON ACTIONLISTENER WON'T FIRE TO PAGEFLOW SCOPED MANAGED-BEAN", was filed which I have been able to find on My Oracle Support

        regards
        Jan Vervecken

        chriscmuir added a comment -

        Developer has been assigned this bug this week and a fix is scheduled by 11.1.2.4.0.

        chriscmuir added a comment -

        While via the bug I can see there has been work done on this issue, unfortunately the developer allocated to the task has left Oracle and the issue has been reassigned. Dropped internal email to see where progress is at.

        CM.

        chriscmuir added a comment -

        From what I can digest, bug 15989335 will be satisified by non published ER 16326880 already fixed for 12.1.3. What I can't see from either the bug or ER will this result in a fix or a change in behaviour?

        At this stage I don't have time to visit the internal 12.1.3 build to determine this, however hopefully I'll do so in the future, or, the 12.1.3 release will be public and you can verify for yourself.

        CM.

        Jan Vervecken added a comment -

        Thank you for the updates Chris.

        Currently bug 15989335 has "Status 96 - Closed, Duplicate Bug" and "Base Bug 16326880".

        *** 07/22/13 11:32 am *** (CHG: Base Bug-> NULL -> 16326880)
        *** 07/22/13 11:32 am *** (CHG: Sta->36)
        *** 07/22/13 11:32 am ***
        *** 09/30/13 02:02 am *** (CHG: Sta->96)
        *** 09/30/13 02:02 am ***
        This bug has not been updated in 69 days.
        The status has been automatically updated to 96 according to this policy:
        http://aseng-wiki.us.oracle.com/asengwiki/x/IwCU8-----8

        regards
        Jan Vervecken

        chriscmuir added a comment -

        Tried to verify the fix for this today, but the requirements for the future release where this has been fixed in terms of icons, packaging and deploying has moved on. Unfortunately I can't commit time to rebuilding your demo app at the moment. So what we'll need to do is wait for that release to go public, get you to rebuild your application, and test on that release.

        CM.

        chriscmuir added a comment -

        Jan, can you test if this is reproducible in the 12.1.3 build please?

        Thanks,

        CM.

        chriscmuir added a comment -

        As there hasn't been an update from Jan, closing issue for now. Reopen if necessary.


          People

          • Assignee:
            Unassigned
            Reporter:
            Jan Vervecken
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: