adfemg
  1. adfemg
  2. ADFEMG-76

bug 11674731 : DCERRORHANDLERIMPL SUB-CLASS SUPER(TRUE) OR SUPER(FALSE)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Labels:
      None

      Description

      hi

      Today I noticed that (documentation?) bug 11674731, "DCERRORHANDLERIMPL SUB-CLASS SUPER(TRUE) OR SUPER(FALSE)", has recently been updated to "Status 32 - Not a Bug. To Filer" without further explanation published:

      *** 12/10/12 11:08 pm *** (CHG: Sta->32)
      *** 12/10/12 11:08 pm ***
      

      In the OTN forum thread "DCErrorHandlerImpl sub-class super(true) or super(false)"
      at https://forums.oracle.com/forums/thread.jspa?threadID=1805078
      I have asked related questions in the past (for which the feedback/answers remain unclear):

      • (q1) Should true or false be passed in the constructor for DCErrorHandlerImpl, and why?
      • (q2) Why is there no difference in behaviour in scenario (sc3) compared to scenario (sc4), although false and true are passed in the constructor for DCErrorHandlerImpl respectively?
      • (q3) Which specific scenarios would illustrate a difference in behaviour when false or true are passed in the constructor for DCErrorHandlerImpl?

      question for this ADFEMG JIRA issue:

      • (q4) Why has bug 11674731 been updated to "Status 32 - Not a Bug. To Filer"?

      many thanks
      Jan Vervecken

        Activity

        chriscmuir added a comment -

        The answer I have is "false".

        CM.

        Jan Vervecken added a comment -

        fyi

        • about 'The answer I have is "false".', answering (q1)
          • The AdfmSampleErrorHandlerImpl class in the sample [1] of the "Catch Me If You Can" article by Frank Nimphius [2] calls super(true).

        regards
        Jan Vervecken

        chriscmuir added a comment -

        Verified oracle.adf.model.binding.DCErrorHandlerImpl now has a default constructor available which takes the guess work out of the super() call. Please verify the change and close this issue if complete.

        CM.

        chriscmuir added a comment -

        No further update, closing issue.

        CM.

        Jan Vervecken added a comment -

        Thank you for the update Chris.

        Currently bug 11674731 has "Status 92 - Closed, Not a Bug".

        *** 12/10/12 11:08 pm *** (CHG: Sta->32)
        *** 12/10/12 11:08 pm ***
        *** 09/26/13 02:02 am *** (CHG: Sta->92)
        *** 09/26/13 02:02 am ***
        This bug has not been updated in 289 days.
        The status has been automatically updated to 92 according to this policy:
        Per http://aseng-wiki.us.oracle.com/asengwiki/x/IwCU8-----8

        regards
        Jan Vervecken


          People

          • Assignee:
            Unassigned
            Reporter:
            Jan Vervecken
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: