Issue Details (XML | Word | Printable)

Key: AGROSENSE-1348
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Minor Minor
Assignee: Johan Reitzema
Reporter: Tom Verhage
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
agrosense

Show timelog with insufficient data on map

Created: 17/Dec/12 10:48 AM   Updated: 17/Jan/13 09:38 AM   Resolved: 17/Jan/13 01:12 AM
Component/s: ISOBUS
Affects Version/s: 12.11
Fix Version/s: 13.01

Time Tracking:
Not Specified

Tags:
Participants: Johan Reitzema and Tom Verhage


 Description  « Hide

Import the taskdata of Bergeijk
Drag timelog 0003 to the map
Double click the layer

Expected: the map can't focus because there is not enough information. Message is displayed, and nothing happens with the map.
Result: The map focusses on latlong 0,0 (somewhere in the ocean)



Johan Reitzema added a comment - 19/Dec/12 10:58 PM

Changeset 2746 (bd400345ea76): improved error handling and UI feedback for incomplete timelog binaries


Tom Verhage added a comment - 16/Jan/13 10:07 AM

Issue is back since refactoring timelogs


Johan Reitzema added a comment - 17/Jan/13 01:12 AM - edited

Changeset: 2782 (90f45d7c4ebf)

Besides being available as a childnode the trajectory is also used to determine the centroid of the parent timelog binary node itself.
The problem had temporarily disappeared when the latter node was using a grid instead of the trajectory.
It was caused by a trajectory consisting of 4 identical points; not clear why (0,0) was returned or why the geometry wasn't considered invalid.
Solved by removing duplicate coordinates when adjacent and returning a point instead of a line when there is only one coordinate left (a valid linestring must have either 0 or >=2 coordinates).


Tom Verhage added a comment - 17/Jan/13 09:38 AM

Tested 17-1-2013