Issue Details (XML | Word | Printable)

Key: AGROSENSE-1404
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Critical Critical
Assignee: Johan Reitzema
Reporter: Timon Veenstra
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
agrosense

Exception when treatmentzone values are close together

Created: 16/Jan/13 09:24 PM   Updated: 23/Jan/13 10:16 AM   Resolved: 23/Jan/13 10:11 AM
Component/s: Tasks
Affects Version/s: SHP-XML Converter 0.0.4
Fix Version/s: 13.01

Time Tracking:
Not Specified

Tags:
Participants: Johan Reitzema, Timon Veenstra and Tom Verhage


 Description  « Hide
  • open a shapefile with 2 treatment zones
  • convert to task
  • open the task
  • change value of one of the treatment zones to a value nearing the other value

Exception is shown, but everything seems to render fine.

javax.media.jai.util.ImagingException: All factories fail for the operation "org.geotools.RasterClassifier"
at javax.media.jai.OperationRegistry.invokeFactory(OperationRegistry.java:1687)
at javax.media.jai.ThreadSafeOperationRegistry.invokeFactory(ThreadSafeOperationRegistry.java:473)
at javax.media.jai.registry.RIFRegistry.create(RIFRegistry.java:332)
at javax.media.jai.RenderedOp.createInstance(RenderedOp.java:819)
at javax.media.jai.RenderedOp.createRendering(RenderedOp.java:867)
at javax.media.jai.RenderedOp.getColorModel(RenderedOp.java:2242)
at org.geotools.renderer.lite.gridcoverage2d.ColorMapNode.execute(ColorMapNode.java:299)
at org.geotools.renderer.lite.gridcoverage2d.ColorMapNode.execute(ColorMapNode.java:55)
at org.geotools.renderer.lite.gridcoverage2d.StyleVisitorCoverageProcessingNodeAdapter$1.execute(StyleVisitorCoverageProcessingNodeAdapter.java:135)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.checkExecuted(BaseCoverageProcessingNode.java:238)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.getOutput(BaseCoverageProcessingNode.java:340)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.getOutput(BaseCoverageProcessingNode.java:45)
at org.geotools.renderer.lite.gridcoverage2d.StyleVisitorCoverageProcessingNodeAdapter.getOutput(StyleVisitorCoverageProcessingNodeAdapter.java:175)
at org.geotools.renderer.lite.gridcoverage2d.ContrastEnhancementNode.execute(ContrastEnhancementNode.java:225)
at org.geotools.renderer.lite.gridcoverage2d.ContrastEnhancementNode.execute(ContrastEnhancementNode.java:75)
at org.geotools.renderer.lite.gridcoverage2d.StyleVisitorCoverageProcessingNodeAdapter$1.execute(StyleVisitorCoverageProcessingNodeAdapter.java:135)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.checkExecuted(BaseCoverageProcessingNode.java:238)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.getOutput(BaseCoverageProcessingNode.java:340)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.getOutput(BaseCoverageProcessingNode.java:45)
at org.geotools.renderer.lite.gridcoverage2d.StyleVisitorCoverageProcessingNodeAdapter.getOutput(StyleVisitorCoverageProcessingNodeAdapter.java:175)
at org.geotools.renderer.lite.gridcoverage2d.SubchainStyleVisitorCoverageProcessingAdapter.execute(SubchainStyleVisitorCoverageProcessingAdapter.java:115)
at org.geotools.renderer.lite.gridcoverage2d.RasterSymbolizerHelper.execute(RasterSymbolizerHelper.java:67)
at org.geotools.renderer.lite.gridcoverage2d.RasterSymbolizerHelper.execute(RasterSymbolizerHelper.java:49)
at org.geotools.renderer.lite.gridcoverage2d.StyleVisitorCoverageProcessingNodeAdapter$1.execute(StyleVisitorCoverageProcessingNodeAdapter.java:135)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.checkExecuted(BaseCoverageProcessingNode.java:238)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.getOutput(BaseCoverageProcessingNode.java:340)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.getOutput(BaseCoverageProcessingNode.java:45)
at org.geotools.renderer.lite.gridcoverage2d.StyleVisitorCoverageProcessingNodeAdapter.getOutput(StyleVisitorCoverageProcessingNodeAdapter.java:175)
at org.geotools.renderer.lite.gridcoverage2d.GridCoverageRenderer.prepareFinalImage(GridCoverageRenderer.java:679)
at org.geotools.renderer.lite.gridcoverage2d.GridCoverageRenderer.paint(GridCoverageRenderer.java:864)
at nl.cloudfarming.client.geoviewer.render.GridCoverage2DRenderer.paint(GridCoverage2DRenderer.java:171)
at nl.cloudfarming.client.geoviewer.render.GridCoverage2DRenderer.paint(GridCoverage2DRenderer.java:56)
at nl.cloudfarming.client.geoviewer.render.GridCoverage2DWidget.paintWidget(GridCoverage2DWidget.java:88)
at org.netbeans.api.visual.widget.Widget.paint(Widget.java:1425)
at org.netbeans.api.visual.widget.Widget.paintChildren(Widget.java:1480)
at org.netbeans.api.visual.widget.Widget.paint(Widget.java:1426)
at org.netbeans.api.visual.widget.Widget.paintChildren(Widget.java:1480)
at org.netbeans.api.visual.widget.Widget.paint(Widget.java:1426)
at org.netbeans.api.visual.widget.SceneComponent.paint(SceneComponent.java:140)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at org.jdesktop.swingx.JXPanel.paint(JXPanel.java:501)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at javax.swing.JLayeredPane.paint(JLayeredPane.java:585)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at org.jdesktop.swingx.JXPanel.paint(JXPanel.java:501)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at org.netbeans.swing.tabcontrol.TabbedContainer.paint(TabbedContainer.java:973)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at javax.swing.JComponent.paintToOffscreen(JComponent.java:5221)
at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(RepaintManager.java:1482)
at javax.swing.RepaintManager$PaintManager.paint(RepaintManager.java:1413)
at javax.swing.RepaintManager.paint(RepaintManager.java:1206)
at javax.swing.JComponent._paintImmediately(JComponent.java:5169)
at javax.swing.JComponent.paintImmediately(JComponent.java:4980)
at javax.swing.JComponent.paintImmediately(JComponent.java:4961)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:770)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:728)
at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:677)
at javax.swing.RepaintManager.access$700(RepaintManager.java:59)
at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1621)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:721)
at java.awt.EventQueue.access$200(EventQueue.java:103)
at java.awt.EventQueue$3.run(EventQueue.java:682)
at java.awt.EventQueue$3.run(EventQueue.java:680)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:691)
at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:158)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Caused by: java.lang.reflect.InvocationTargetException
at sun.reflect.GeneratedMethodAccessor66.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:601)
at javax.media.jai.FactoryCache.invoke(FactoryCache.java:122)
at javax.media.jai.OperationRegistry.invokeFactory(OperationRegistry.java:1674)
... 85 more
Caused by: java.lang.AssertionError: Domain description:
name=ColorMapEntry2
input range=[]
wkt transform=PARAM_MT["Affine",
PARAMETER["num_row", 2],
PARAMETER["num_col", 2],
PARAMETER["elt_0_0", -14073748835532800.0],
PARAMETER["elt_0_1", 140737488355328032.0]]
output range=[25, 50]
colors=java.awt.Color[r=0,g=96,b=255],java.awt.Color[r=0,g=96,b=255]
at org.geotools.referencing.piecewise.PiecewiseUtilities.isSorted(PiecewiseUtilities.java:185)
at org.geotools.referencing.piecewise.DefaultDomain1D.init(DefaultDomain1D.java:232)
at org.geotools.referencing.piecewise.DefaultDomain1D.<init>(DefaultDomain1D.java:145)
at org.geotools.referencing.piecewise.DefaultPiecewiseTransform1D.<init>(DefaultPiecewiseTransform1D.java:51)
at org.geotools.renderer.lite.gridcoverage2d.LinearColorMap.initColorModel(LinearColorMap.java:442)
at org.geotools.renderer.lite.gridcoverage2d.LinearColorMap.getColorModel(LinearColorMap.java:330)
at org.geotools.renderer.lite.gridcoverage2d.RasterClassifier.prepareLayout(RasterClassifier.java:116)
at org.geotools.renderer.lite.gridcoverage2d.RasterClassifier.<init>(RasterClassifier.java:89)
at org.geotools.renderer.lite.gridcoverage2d.RasterClassifier.<init>(RasterClassifier.java:57)
at org.geotools.renderer.lite.gridcoverage2d.RasterClassifier$CRIF.create(RasterClassifier.java:370)
... 90 more
Caused by:
java.lang.reflect.InvocationTargetException
at sun.reflect.GeneratedMethodAccessor66.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:601)
at javax.media.jai.FactoryCache.invoke(FactoryCache.java:122)
at javax.media.jai.OperationRegistry.invokeFactory(OperationRegistry.java:1674)
at javax.media.jai.ThreadSafeOperationRegistry.invokeFactory(ThreadSafeOperationRegistry.java:473)
at javax.media.jai.registry.RIFRegistry.create(RIFRegistry.java:332)
at javax.media.jai.RenderedOp.createInstance(RenderedOp.java:819)
at javax.media.jai.RenderedOp.createRendering(RenderedOp.java:867)
at javax.media.jai.RenderedOp.getColorModel(RenderedOp.java:2242)
at org.geotools.renderer.lite.gridcoverage2d.ColorMapNode.execute(ColorMapNode.java:299)
at org.geotools.renderer.lite.gridcoverage2d.ColorMapNode.execute(ColorMapNode.java:55)
at org.geotools.renderer.lite.gridcoverage2d.StyleVisitorCoverageProcessingNodeAdapter$1.execute(StyleVisitorCoverageProcessingNodeAdapter.java:135)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.checkExecuted(BaseCoverageProcessingNode.java:238)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.getOutput(BaseCoverageProcessingNode.java:340)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.getOutput(BaseCoverageProcessingNode.java:45)
at org.geotools.renderer.lite.gridcoverage2d.StyleVisitorCoverageProcessingNodeAdapter.getOutput(StyleVisitorCoverageProcessingNodeAdapter.java:175)
at org.geotools.renderer.lite.gridcoverage2d.ContrastEnhancementNode.execute(ContrastEnhancementNode.java:225)
at org.geotools.renderer.lite.gridcoverage2d.ContrastEnhancementNode.execute(ContrastEnhancementNode.java:75)
at org.geotools.renderer.lite.gridcoverage2d.StyleVisitorCoverageProcessingNodeAdapter$1.execute(StyleVisitorCoverageProcessingNodeAdapter.java:135)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.checkExecuted(BaseCoverageProcessingNode.java:238)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.getOutput(BaseCoverageProcessingNode.java:340)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.getOutput(BaseCoverageProcessingNode.java:45)
at org.geotools.renderer.lite.gridcoverage2d.StyleVisitorCoverageProcessingNodeAdapter.getOutput(StyleVisitorCoverageProcessingNodeAdapter.java:175)
at org.geotools.renderer.lite.gridcoverage2d.SubchainStyleVisitorCoverageProcessingAdapter.execute(SubchainStyleVisitorCoverageProcessingAdapter.java:115)
at org.geotools.renderer.lite.gridcoverage2d.RasterSymbolizerHelper.execute(RasterSymbolizerHelper.java:67)
at org.geotools.renderer.lite.gridcoverage2d.RasterSymbolizerHelper.execute(RasterSymbolizerHelper.java:49)
at org.geotools.renderer.lite.gridcoverage2d.StyleVisitorCoverageProcessingNodeAdapter$1.execute(StyleVisitorCoverageProcessingNodeAdapter.java:135)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.checkExecuted(BaseCoverageProcessingNode.java:238)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.getOutput(BaseCoverageProcessingNode.java:340)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.getOutput(BaseCoverageProcessingNode.java:45)
at org.geotools.renderer.lite.gridcoverage2d.StyleVisitorCoverageProcessingNodeAdapter.getOutput(StyleVisitorCoverageProcessingNodeAdapter.java:175)
at org.geotools.renderer.lite.gridcoverage2d.GridCoverageRenderer.prepareFinalImage(GridCoverageRenderer.java:679)
at org.geotools.renderer.lite.gridcoverage2d.GridCoverageRenderer.paint(GridCoverageRenderer.java:864)
at nl.cloudfarming.client.geoviewer.render.GridCoverage2DRenderer.paint(GridCoverage2DRenderer.java:171)
at nl.cloudfarming.client.geoviewer.render.GridCoverage2DRenderer.paint(GridCoverage2DRenderer.java:56)
at nl.cloudfarming.client.geoviewer.render.GridCoverage2DWidget.paintWidget(GridCoverage2DWidget.java:88)
at org.netbeans.api.visual.widget.Widget.paint(Widget.java:1425)
at org.netbeans.api.visual.widget.Widget.paintChildren(Widget.java:1480)
at org.netbeans.api.visual.widget.Widget.paint(Widget.java:1426)
at org.netbeans.api.visual.widget.Widget.paintChildren(Widget.java:1480)
at org.netbeans.api.visual.widget.Widget.paint(Widget.java:1426)
at org.netbeans.api.visual.widget.SceneComponent.paint(SceneComponent.java:140)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at org.jdesktop.swingx.JXPanel.paint(JXPanel.java:501)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at javax.swing.JLayeredPane.paint(JLayeredPane.java:585)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at org.jdesktop.swingx.JXPanel.paint(JXPanel.java:501)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at org.netbeans.swing.tabcontrol.TabbedContainer.paint(TabbedContainer.java:973)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at javax.swing.JComponent.paintToOffscreen(JComponent.java:5221)
at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(RepaintManager.java:1482)
at javax.swing.RepaintManager$PaintManager.paint(RepaintManager.java:1413)
at javax.swing.RepaintManager.paint(RepaintManager.java:1206)
at javax.swing.JComponent._paintImmediately(JComponent.java:5169)
at javax.swing.JComponent.paintImmediately(JComponent.java:4980)
at javax.swing.JComponent.paintImmediately(JComponent.java:4961)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:770)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:728)
at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:677)
at javax.swing.RepaintManager.access$700(RepaintManager.java:59)
at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1621)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:721)
at java.awt.EventQueue.access$200(EventQueue.java:103)
at java.awt.EventQueue$3.run(EventQueue.java:682)
at java.awt.EventQueue$3.run(EventQueue.java:680)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:691)
at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:158)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Caused by: java.lang.AssertionError: Domain description:
name=ColorMapEntry2
input range=[]
wkt transform=PARAM_MT["Affine",
PARAMETER["num_row", 2],
PARAMETER["num_col", 2],
PARAMETER["elt_0_0", -14073748835532800.0],
PARAMETER["elt_0_1", 140737488355328032.0]]
output range=[25, 50]
colors=java.awt.Color[r=0,g=96,b=255],java.awt.Color[r=0,g=96,b=255]
at org.geotools.referencing.piecewise.PiecewiseUtilities.isSorted(PiecewiseUtilities.java:185)
at org.geotools.referencing.piecewise.DefaultDomain1D.init(DefaultDomain1D.java:232)
at org.geotools.referencing.piecewise.DefaultDomain1D.<init>(DefaultDomain1D.java:145)
at org.geotools.referencing.piecewise.DefaultPiecewiseTransform1D.<init>(DefaultPiecewiseTransform1D.java:51)
at org.geotools.renderer.lite.gridcoverage2d.LinearColorMap.initColorModel(LinearColorMap.java:442)
at org.geotools.renderer.lite.gridcoverage2d.LinearColorMap.getColorModel(LinearColorMap.java:330)
at org.geotools.renderer.lite.gridcoverage2d.RasterClassifier.prepareLayout(RasterClassifier.java:116)
at org.geotools.renderer.lite.gridcoverage2d.RasterClassifier.<init>(RasterClassifier.java:89)
at org.geotools.renderer.lite.gridcoverage2d.RasterClassifier.<init>(RasterClassifier.java:57)
at org.geotools.renderer.lite.gridcoverage2d.RasterClassifier$CRIF.create(RasterClassifier.java:370)
... 90 more
Caused: org.geotools.coverage.processing.CoverageProcessingException
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.getOutput(BaseCoverageProcessingNode.java:342)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.getOutput(BaseCoverageProcessingNode.java:45)
at org.geotools.renderer.lite.gridcoverage2d.StyleVisitorCoverageProcessingNodeAdapter.getOutput(StyleVisitorCoverageProcessingNodeAdapter.java:175)
at org.geotools.renderer.lite.gridcoverage2d.ContrastEnhancementNode.execute(ContrastEnhancementNode.java:225)
at org.geotools.renderer.lite.gridcoverage2d.ContrastEnhancementNode.execute(ContrastEnhancementNode.java:75)
at org.geotools.renderer.lite.gridcoverage2d.StyleVisitorCoverageProcessingNodeAdapter$1.execute(StyleVisitorCoverageProcessingNodeAdapter.java:135)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.checkExecuted(BaseCoverageProcessingNode.java:238)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.getOutput(BaseCoverageProcessingNode.java:340)
Caused: org.geotools.coverage.processing.CoverageProcessingException
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.getOutput(BaseCoverageProcessingNode.java:342)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.getOutput(BaseCoverageProcessingNode.java:45)
at org.geotools.renderer.lite.gridcoverage2d.StyleVisitorCoverageProcessingNodeAdapter.getOutput(StyleVisitorCoverageProcessingNodeAdapter.java:175)
at org.geotools.renderer.lite.gridcoverage2d.SubchainStyleVisitorCoverageProcessingAdapter.execute(SubchainStyleVisitorCoverageProcessingAdapter.java:115)
at org.geotools.renderer.lite.gridcoverage2d.RasterSymbolizerHelper.execute(RasterSymbolizerHelper.java:67)
at org.geotools.renderer.lite.gridcoverage2d.RasterSymbolizerHelper.execute(RasterSymbolizerHelper.java:49)
at org.geotools.renderer.lite.gridcoverage2d.StyleVisitorCoverageProcessingNodeAdapter$1.execute(StyleVisitorCoverageProcessingNodeAdapter.java:135)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.checkExecuted(BaseCoverageProcessingNode.java:238)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.getOutput(BaseCoverageProcessingNode.java:340)
Caused: org.geotools.coverage.processing.CoverageProcessingException
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.getOutput(BaseCoverageProcessingNode.java:342)
at org.geotools.renderer.lite.gridcoverage2d.BaseCoverageProcessingNode.getOutput(BaseCoverageProcessingNode.java:45)
at org.geotools.renderer.lite.gridcoverage2d.StyleVisitorCoverageProcessingNodeAdapter.getOutput(StyleVisitorCoverageProcessingNodeAdapter.java:175)
at org.geotools.renderer.lite.gridcoverage2d.GridCoverageRenderer.prepareFinalImage(GridCoverageRenderer.java:679)
at org.geotools.renderer.lite.gridcoverage2d.GridCoverageRenderer.paint(GridCoverageRenderer.java:864)
at nl.cloudfarming.client.geoviewer.render.GridCoverage2DRenderer.paint(GridCoverage2DRenderer.java:171)
at nl.cloudfarming.client.geoviewer.render.GridCoverage2DRenderer.paint(GridCoverage2DRenderer.java:56)
at nl.cloudfarming.client.geoviewer.render.GridCoverage2DWidget.paintWidget(GridCoverage2DWidget.java:88)
at org.netbeans.api.visual.widget.Widget.paint(Widget.java:1425)
at org.netbeans.api.visual.widget.Widget.paintChildren(Widget.java:1480)
at org.netbeans.api.visual.widget.Widget.paint(Widget.java:1426)
at org.netbeans.api.visual.widget.Widget.paintChildren(Widget.java:1480)
at org.netbeans.api.visual.widget.Widget.paint(Widget.java:1426)
at org.netbeans.api.visual.widget.SceneComponent.paint(SceneComponent.java:140)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at org.jdesktop.swingx.JXPanel.paint(JXPanel.java:501)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at javax.swing.JLayeredPane.paint(JLayeredPane.java:585)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at org.jdesktop.swingx.JXPanel.paint(JXPanel.java:501)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at org.netbeans.swing.tabcontrol.TabbedContainer.paint(TabbedContainer.java:973)
at javax.swing.JComponent.paintChildren(JComponent.java:887)
at javax.swing.JComponent.paint(JComponent.java:1063)
at javax.swing.JComponent.paintToOffscreen(JComponent.java:5221)
at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(RepaintManager.java:1482)
at javax.swing.RepaintManager$PaintManager.paint(RepaintManager.java:1413)
at javax.swing.RepaintManager.paint(RepaintManager.java:1206)
at javax.swing.JComponent._paintImmediately(JComponent.java:5169)
at javax.swing.JComponent.paintImmediately(JComponent.java:4980)
at javax.swing.JComponent.paintImmediately(JComponent.java:4961)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:770)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:728)
at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:677)
at javax.swing.RepaintManager.access$700(RepaintManager.java:59)
at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1621)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:721)
at java.awt.EventQueue.access$200(EventQueue.java:103)
at java.awt.EventQueue$3.run(EventQueue.java:682)
at java.awt.EventQueue$3.run(EventQueue.java:680)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:691)
at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:158)
[catch] at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)



Johan Reitzema added a comment - 23/Jan/13 10:11 AM

Changeset: 2792 (b7d05afa0dec)

+ improvement: adapt the number of decimals used in legend labels to the size of the displayed range.


Tom Verhage added a comment - 23/Jan/13 10:16 AM

Tested. Works as expected.
Refreshing the task/legend on the map will be fixed in issue http://java.net/jira/browse/AGROSENSE-1372