Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: .9.8
    • Fix Version/s: milestone 1
    • Component/s: widgets
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      380

      Description

      I'm using Netbeans 6.5 with jmaki 2.6 for a webproject. After upgrading to this
      jmaki version the widget colorpicker gives the following error:

      Error loading jmaki.widgets.yahoo.colorpicker.Widget : id=yahoo_colorpicker2
      Script: undefined (line: 241).
      Message: YAHOO.widget.Overlay is not a constructor

      I have tried to reproduce this error by setting up a new web project with jmaki
      framework, just include the colorpicker widget into the page and yes the same error.
      If you add the widget RGBslider before the colorpicker it works!
      So, I included the RGBslider libs to the libs of colorpicker widget.json and
      removed the unused libs.
      The complete list:
      "config" : {
      "type": {
      "id" : "yahoo.colorpicker",
      "libs": [
      "../resources/libs/yahoo/v2.6.0/dragdrop/dragdrop-min.js",
      "../resources/libs/yahoo/v2.6.0/container/container_core-min.js",
      "../resources/libs/yahoo/v2.6.0/utilities/utilities.js",
      "../resources/libs/yahoo/v2.6.0/slider/slider-min.js",
      "../resources/libs/yahoo/v2.6.0/colorpicker/colorpicker-min.js"

      Can you add the dragdrop and the container lib into the next release of jmaki?

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            gmurray71
            Reporter:
            simonk1
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: