atmosphere
  1. atmosphere
  2. ATMOSPHERE-143

Exception about Tomcat 7 when using Tomcat6

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.8
    • Fix Version/s: 0.8
    • Component/s: runtime
    • Labels:
      None

      Description

      INFO: Starting Servlet Engine: Apache Tomcat/6.0.26
      SLF4J: Class path contains multiple SLF4J bindings.
      SLF4J: Found binding in [jar:file:/F:/workspaces/workspace_eclipse/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/wtpwebapps/AtmoSubscribeStreamingDemo/WEB-INF/lib/slf4j-log4j12-1.6.1.jar!/org/slf4j/impl/StaticLoggerBinder.class]
      SLF4J: Found binding in [jar:file:/F:/workspaces/workspace_eclipse/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/wtpwebapps/AtmoSubscribeStreamingDemo/WEB-INF/lib/slf4j-simple-1.6.1.jar!/org/slf4j/impl/StaticLoggerBinder.class]
      SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
      [main] INFO org.atmosphere.cpr.AtmosphereServlet - initializing atmosphere framework: 0.8-SNAPSHOT
      [main] INFO org.atmosphere.cpr.AtmosphereServlet - using default broadcaster class: class org.atmosphere.cpr.DefaultBroadcaster
      [main] INFO org.atmosphere.cpr.AtmosphereServlet - Atmosphere is using comet support: org.atmosphere.container.Tomcat7CometSupport running under container: Apache Tomcat/6.0.26
      [main] INFO org.atmosphere.cpr.AtmosphereServlet - using broadcaster class: org.atmosphere.cpr.DefaultBroadcaster
      [main] INFO org.atmosphere.handler.ReflectorServletProcessor - Installing Servlet org.apache.struts.action.ActionServlet
      [main] INFO org.atmosphere.cpr.AtmosphereServlet - started atmosphere framework: 0.8-SNAPSHOT
      2011-07-04 09:58:11 org.apache.coyote.http11.Http11Protocol start
      INFO: Démarrage de Coyote HTTP/1.1 sur http-8080
      2011-07-04 09:58:11 org.apache.jk.common.ChannelSocket init
      INFO: JK: ajp13 listening on /0.0.0.0:8009
      2011-07-04 09:58:11 org.apache.jk.server.JkMain start
      INFO: Jk running ID=0 time=0/62 config=null
      2011-07-04 09:58:11 org.apache.catalina.startup.Catalina start
      INFO: Server startup in 2291 ms
      [http-8080-1] WARN org.atmosphere.cpr.AtmosphereServlet - Tomcat failed to detect this is a Comet application because context.xml is missing or the Http11NioProtocol Connector is not enabled.
      If that's not the case, you can also remove META-INF/context.xml and WEB-INF/lib/atmosphere-compat-tomcat.jar
      java.lang.IllegalStateException: Tomcat failed to detect this is a Comet application because context.xml is missing or the Http11NioProtocol Connector is not enabled.
      If that's not the case, you can also remove META-INF/context.xml and WEB-INF/lib/atmosphere-compat-tomcat.jar
      at org.atmosphere.container.Tomcat7CometSupport.<clinit>(Tomcat7CometSupport.java:45)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
      at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
      at org.atmosphere.cpr.DefaultCometSupportResolver.newCometSupport(DefaultCometSupportResolver.java:187)
      at org.atmosphere.cpr.DefaultCometSupportResolver.resolveWebSocket(DefaultCometSupportResolver.java:245)
      at org.atmosphere.cpr.DefaultCometSupportResolver.resolve(DefaultCometSupportResolver.java:233)
      at org.atmosphere.cpr.AtmosphereServlet.autoDetectContainer(AtmosphereServlet.java:973)
      at org.atmosphere.cpr.AtmosphereServlet.init(AtmosphereServlet.java:571)
      at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1173)
      at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:993)
      at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4187)
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:4496)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
      at org.apache.catalina.core.StandardHost.start(StandardHost.java:785)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
      at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
      at org.apache.catalina.core.StandardService.start(StandardService.java:519)
      at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
      at org.apache.catalina.startup.Catalina.start(Catalina.java:581)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
      at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)
      [http-8080-1] WARN org.atmosphere.cpr.AtmosphereServlet - failed using comet support: org.atmosphere.container.Tomcat7CometSupport, error: Tomcat failed to detect this is a Comet application because context.xml is missing or the Http11NioProtocol Connector is not enabled.
      If that's not the case, you can also remove META-INF/context.xml and WEB-INF/lib/atmosphere-compat-tomcat.jar
      [http-8080-1] WARN org.atmosphere.cpr.AtmosphereServlet - Using BlockingIOCometSupport.

      HERE MY WEB.XML

      <web-app>
      <display-name>Struts-Atmosphere Comet Application</display-name>
      <servlet>
      <servlet-name>MeteorServlet</servlet-name>
      <servlet-class>org.atmosphere.cpr.MeteorServlet</servlet-class>
      <init-param>
      <param-name>org.atmosphere.servlet</param-name>
      <param-value>org.apache.struts.action.ActionServlet</param-value>
      </init-param>
      <init-param>
      <param-name>org.atmosphere.useWebSocket</param-name>
      <param-value>true</param-value>
      </init-param>
      <init-param>
      <param-name>org.atmosphere.useNative</param-name>
      <param-value>true</param-value>
      </init-param>

      <load-on-startup>0</load-on-startup>
      </servlet>
      <servlet-mapping>
      <servlet-name>MeteorServlet</servlet-name>
      <url-pattern>*.do</url-pattern>
      </servlet-mapping>

      <!-- The Usual Welcome File List -->
      <welcome-file-list>
      <welcome-file>index.jsp</welcome-file>
      </welcome-file-list>

      </web-app>

      POM.XML

      <properties>
      <junit.version>4.8</junit.version>
      <javassist.version>3.14.0-GA</javassist.version>
      <jdk5.tools>c:/jdk/lib/tools.jar</jdk5.tools>
      <slf4j.version>1.6.1</slf4j.version>
      <atmosphere.version>0.8-SNAPSHOT</atmosphere.version>
      <jersey.version>1.5</jersey.version>

      </properties>

      <dependencies>
      <!-- Junit -->
      <dependency>
      <groupId>junit</groupId>
      <artifactId>junit</artifactId>
      <version>$

      {junit.version}

      </version>
      <scope>test</scope>
      </dependency>

      <dependency>
      <groupId>org.apache.struts</groupId>
      <artifactId>struts-core</artifactId>
      <version>1.3.10</version>
      </dependency>
      <dependency>
      <groupId>org.apache.struts</groupId>
      <artifactId>struts-taglib</artifactId>
      <version>1.3.10</version>
      </dependency>
      <dependency>
      <groupId>org.apache.struts</groupId>
      <artifactId>struts-tiles</artifactId>
      <version>1.3.10</version>
      </dependency>
      <dependency>
      <groupId>org.apache.struts</groupId>
      <artifactId>struts-extras</artifactId>
      <version>1.3.10</version>
      </dependency>

      <dependency>
      <groupId>org.codehaus.jackson</groupId>
      <artifactId>jackson-core-lgpl</artifactId>
      <version>1.7.5</version>
      </dependency>
      <dependency>
      <groupId>org.codehaus.jackson</groupId>
      <artifactId>jackson-mapper-lgpl</artifactId>
      <version>1.7.5</version>
      </dependency>

      <!--
      <dependency>
      <groupId>com.sun</groupId>
      <artifactId>tools</artifactId>
      <version>1.5.0</version>
      <scope>system</scope>
      <systemPath>$

      {jdk5.tools}

      </systemPath>
      </dependency>
      -->
      <dependency>
      <groupId>org.javassist</groupId>
      <artifactId>javassist</artifactId>
      <version>$

      {javassist.version}

      </version>
      </dependency>

      <!-- Servlet & Jsp -->
      <dependency>
      <groupId>javax.servlet</groupId>
      <artifactId>servlet-api</artifactId>
      <version>2.5</version>
      <scope>provided</scope>
      </dependency>

      <!-- Logging -->
      <dependency>
      <groupId>org.slf4j</groupId>
      <artifactId>slf4j-simple</artifactId>
      <version>$

      {slf4j.version}</version>
      </dependency>

      <dependency>
      <groupId>org.slf4j</groupId>
      <artifactId>slf4j-api</artifactId>
      <version>${slf4j.version}

      </version>
      </dependency>

      <dependency>
      <groupId>org.slf4j</groupId>
      <artifactId>slf4j-log4j12</artifactId>
      <version>$

      {slf4j.version}

      </version>
      </dependency>

      <!-- Atmosphere -->
      <dependency>
      <groupId>org.atmosphere</groupId>
      <artifactId>atmosphere-jquery</artifactId>
      <version>$

      {atmosphere.version}</version>
      <type>war</type>
      </dependency>
      <dependency>
      <groupId>org.atmosphere</groupId>
      <artifactId>atmosphere-jersey</artifactId>
      <version>${atmosphere.version}

      </version>
      </dependency>
      <dependency>
      <groupId>org.atmosphere</groupId>
      <artifactId>atmosphere-runtime</artifactId>
      <version>$

      {atmosphere.version}

      </version>
      </dependency>

      <!-- ACTIVE MQ -->
      <dependency>
      <groupId>org.apache.activemq</groupId>
      <artifactId>activemq-core</artifactId>
      <version>5.5.0</version>
      </dependency>

      </dependencies>

        Activity

        jfarcand added a comment -

        Salut,

        please make sure you are using the latest SNAPSHOT version as I did fixed that one. Close the bug if I'm right.

        A+

        • Jeanfrancois
        jfarcand added a comment -

        OK using the latest 0.8-SNAPSHOT I can't reproduce the issue. I used the atmosphere-chat sample to test.

        survivant added a comment -

        I still have the problem.

        #1 - I deleted my m2 repository

        #2 - I added this in my pom.xml

        <repository>
        <id>atmo-repo</id>
        <name>atmo-repo</name>
        <url>http://oss.sonatype.org/content/repositories/snapshots/</url>
        </repository>

        the reason is that Maven complain that atmosphere-runtime-0.8-SNAPSHOOT wasn't found

        #3 - redeploy my application

        #4 here the log when I start my application

        INFO: Starting Servlet Engine: Apache Tomcat/6.0.26
        SLF4J: Class path contains multiple SLF4J bindings.
        SLF4J: Found binding in [jar:file:/F:/workspaces/workspace_eclipse/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/wtpwebapps/AtmoSubscribeStreamingDemo/WEB-INF/lib/slf4j-log4j12-1.6.1.jar!/org/slf4j/impl/StaticLoggerBinder.class]
        SLF4J: Found binding in [jar:file:/F:/workspaces/workspace_eclipse/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/wtpwebapps/AtmoSubscribeStreamingDemo/WEB-INF/lib/slf4j-simple-1.6.1.jar!/org/slf4j/impl/StaticLoggerBinder.class]
        SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
        [main] INFO org.atmosphere.cpr.AtmosphereServlet - initializing atmosphere framework: 0.8-SNAPSHOT
        [main] INFO org.atmosphere.cpr.AtmosphereServlet - using default broadcaster class: class org.atmosphere.cpr.DefaultBroadcaster
        [main] INFO org.atmosphere.cpr.AtmosphereServlet - Atmosphere is using comet support: org.atmosphere.container.Tomcat7CometSupport running under container: Apache Tomcat/6.0.26
        [main] INFO org.atmosphere.cpr.AtmosphereServlet - using broadcaster class: org.atmosphere.cpr.DefaultBroadcaster
        [main] INFO org.atmosphere.handler.ReflectorServletProcessor - Installing Servlet org.apache.struts.action.ActionServlet
        [main] INFO org.atmosphere.cpr.AtmosphereServlet - started atmosphere framework: 0.8-SNAPSHOT
        2011-07-06 12:00:13 org.apache.coyote.http11.Http11Protocol start
        ...

        #5- do a connect from the client and see that in the log

        [http-8080-1] WARN org.atmosphere.cpr.AtmosphereServlet - Tomcat failed to detect this is a Comet application because context.xml is missing or the Http11NioProtocol Connector is not enabled.
        If that's not the case, you can also remove META-INF/context.xml and WEB-INF/lib/atmosphere-compat-tomcat.jar
        java.lang.IllegalStateException: Tomcat failed to detect this is a Comet application because context.xml is missing or the Http11NioProtocol Connector is not enabled.
        If that's not the case, you can also remove META-INF/context.xml and WEB-INF/lib/atmosphere-compat-tomcat.jar
        at org.atmosphere.container.Tomcat7CometSupport.<clinit>(Tomcat7CometSupport.java:45)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
        at org.atmosphere.cpr.DefaultCometSupportResolver.newCometSupport(DefaultCometSupportResolver.java:187)
        at org.atmosphere.cpr.DefaultCometSupportResolver.resolveWebSocket(DefaultCometSupportResolver.java:245)
        at org.atmosphere.cpr.DefaultCometSupportResolver.resolve(DefaultCometSupportResolver.java:233)
        at org.atmosphere.cpr.AtmosphereServlet.autoDetectContainer(AtmosphereServlet.java:973)
        at org.atmosphere.cpr.AtmosphereServlet.init(AtmosphereServlet.java:571)
        at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1173)
        at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:993)
        at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4187)
        at org.apache.catalina.core.StandardContext.start(StandardContext.java:4496)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
        at org.apache.catalina.core.StandardHost.start(StandardHost.java:785)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
        at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
        at org.apache.catalina.core.StandardService.start(StandardService.java:519)
        at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
        at org.apache.catalina.startup.Catalina.start(Catalina.java:581)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)
        [http-8080-1] WARN org.atmosphere.cpr.AtmosphereServlet - failed using comet support: org.atmosphere.container.Tomcat7CometSupport, error: Tomcat failed to detect this is a Comet application because context.xml is missing or the Http11NioProtocol Connector is not enabled.
        If that's not the case, you can also remove META-INF/context.xml and WEB-INF/lib/atmosphere-compat-tomcat.jar
        [http-8080-1] WARN org.atmosphere.cpr.AtmosphereServlet - Using BlockingIOCometSupport.
        [http-8080-1] DEBUG org.atmosphere.cpr.AsynchronousProcessor - (suspend) invoked:

        #6 - is it that the release in maven repository doesn't contain the latest version ?

        jfarcand added a comment -

        Hum, I'm still unable to reproduce the issue. Can you checkout the workspace, build it and see? Just tested on a fresh computer. I think your atmosphere-compat-tomcat.jar is not up to date.

        A+

        jfarcand added a comment -

        This exception is expected if the NIO or APR connector aren't enabled.


          People

          • Assignee:
            Unassigned
            Reporter:
            survivant
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: