a-jar-stdio-terminal
  1. a-jar-stdio-terminal
  2. A_JAR_STDIO_TERMINAL-2

The demo application hangs and shows serious bug in Java classes

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Duplicate
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: www
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      2

      Description

      Enter a number: 33
      Sqrt is: 5.744562646538029
      Waits for 2 seconds (no typeahead!)
      Enter a number: 2
      (THEN IT DID NOT RESPOND TO ANY USER INPUT, JUST HUNG!)

      I have also experienced the the Array Index Out of Bounds experienced by the
      user who submitted the Issue #1. The classes in this project would be very
      useful for a Java plot package I building (using JFreeChart), but the basic
      demo shows there is a serious bug somewhere? I am including the screen capture
      from running the demo a second time. Please fix this....

      Enter a number: 4
      Sqrt is: 2.0
      Cant invoke main() of "StdioDemoMainClass"
      java.lang.ArrayIndexOutOfBoundsException
      at java.lang.System.arraycopy(Native Method)
      at javax.swing.text.BoxView.updateLayoutArray(Unknown Source)
      at javax.swing.text.BoxView.replace(Unknown Source)
      at javax.swing.text.View.removeAll(Unknown Source)
      at javax.swing.text.FlowView$FlowStrategy.layout(Unknown Source)
      at javax.swing.text.FlowView.layout(Unknown Source)
      at javax.swing.text.BoxView.setSize(Unknown Source)
      at javax.swing.text.BoxView.updateChildSizes(Unknown Source)
      at javax.swing.text.BoxView.setSpanOnAxis(Unknown Source)
      at javax.swing.text.BoxView.layout(Unknown Source)
      at javax.swing.text.BoxView.setSize(Unknown Source)
      at javax.swing.plaf.basic.BasicTextUI$RootView.setSize(Unknown Source)
      at javax.swing.plaf.basic.BasicTextUI.getPreferredSize(Unknown Source)
      at javax.swing.JComponent.getPreferredSize(Unknown Source)
      at javax.swing.JEditorPane.getPreferredSize(Unknown Source)
      at javax.swing.ScrollPaneLayout.layoutContainer(Unknown Source)
      at java.awt.Container.layout(Unknown Source)
      at java.awt.Container.doLayout(Unknown Source)
      at java.awt.Container.validateTree(Unknown Source)
      at java.awt.Container.validateTree(Unknown Source)
      at java.awt.Container.validateTree(Unknown Source)
      at java.awt.Container.validateTree(Unknown Source)
      at java.awt.Container.validateTree(Unknown Source)
      at java.awt.Container.validate(Unknown Source)
      at java.awt.Window.show(Unknown Source)
      at java.awt.Component.show(Unknown Source)
      at java.awt.Component.setVisible(Unknown Source)
      at net.java.dev.a_jar_stdio_terminal.StdioTerm.configureDisplay
      (StdioTerm.java:128)
      at net.java.dev.a_jar_stdio_terminal.OutStrmAdapter.write
      (OutStrmAdapter.java:53)
      at java.io.PrintStream.write(Unknown Source)
      at sun.nio.cs.StreamEncoder$CharsetSE.writeBytes(Unknown Source)
      at sun.nio.cs.StreamEncoder$CharsetSE.implFlushBuffer(Unknown Source)
      at sun.nio.cs.StreamEncoder.flushBuffer(Unknown Source)
      at java.io.OutputStreamWriter.flushBuffer(Unknown Source)
      at java.io.PrintStream.newLine(Unknown Source)
      at java.io.PrintStream.println(Unknown Source)
      at StdioDemoMainClass.main(StdioDemoMainClass.java:55)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at net.java.dev.a_jar_stdio_terminal.StdioTerm.main(StdioTerm.java:251)

        Activity

        ankhman added a comment -

        This may be a problem with Java 1.5, since prior to this the application may
        have actually worked?

        sanjay_dasgupta added a comment -

        Obviously a duplicate of #1

            • This issue has been marked as a duplicate of 1 ***

          People

          • Assignee:
            sanjay_dasgupta
            Reporter:
            ankhman
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: