Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Labels:
      None
    • Environment:

      Windows 7, NetBeans 7.3.1

      Description

      When I open the project (from the SVN repository) in NetBeans 7.3.1, I get the following error:

      Some problems were encountered while processing the POMs: [ERROR] 'dependencies.dependency.version' for org.jboss.arquillian.junit:arquillian-junit-container:jar is missing. @line 62, column 21.

      This problem is resolved by adding the version number 1.1.0.Final to the arquillian-junit-container dependency element of the POM.

        Activity

        reza_rahman added a comment -

        Could you kindly include a screenshot? I am unable to reproduce this and it might be a NetBeans bug.

        rcervera added a comment -

        I can't find how to add a file in this JIRA interface, so I sent you a screenshot to your e-mail.

        Kim Haase added a comment -

        I ran into this last week when I first tried to load the app. I fixed the problem the way you describe, and got the pom to load. Then I forgot about it.

        This week, after I reverted the pom files I'd changed (because I'd forgotten what I'd done and wanted to load the project in its current state) the pom also failed to load, but it seemed to be complaining about this line – it never heard of gfv4ee7:

        <netbeans.hint.deploy.server>gfv4ee7</netbeans.hint.deploy.server>

        After I got rid of that line, the pom loaded all right. But I think the reason is that I already had downloaded the arquillian jar, so it no longer complained about the absent version element. It's still not complaining. That's probably why Reza can't reproduce the problem.

        It's Maven being Maven.

        rcervera added a comment -

        Probably the NetBeans XML configuration files should be removed, especially if they do not contain any valuable setting. That's what we do with the tutorial examples to avoid issues when the user has configured GF on NetBeans with a different name than we did.

        rcervera added a comment -

        NetBeans POM error (no longer occurring).

        rcervera added a comment -

        Closing this as discussed with Reza. We also think that testing this app on a fresh machine should provide an indication of whether users will experience any of these issues.

        reza_rahman added a comment -

        It might be a good idea to report some of this for NetBeans - we may be the first people coming across the issues and they are actually more pervasive. I've reported a number of GlassFish and NetBeans bugs through the project.

        reza_rahman added a comment -

        I tried with a fresh install and do indeed see the issue. I am reopening this bug and filing an issue for NetBeans: https://netbeans.org/bugzilla/show_bug.cgi?id=234113. I'll close it when I confirm the issue is resolved in NetBeans.

        reza_rahman added a comment -

        I am closing this upon "resolution" of the underlying NetBeans issue. However, I made a note in our documentation warning users about NetBeans usability.


          People

          • Assignee:
            reza_rahman
            Reporter:
            rcervera
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: