I don't completely like the "single" flag in the AbstractDataReader and the "next"Method in the converter. Refactoring idea: Converter with only convert(...) and a ListConverter with next(...) and hasMoreData(...) < like it is done in the InputStreamConverter. Based on this there will be a AbstractDataReader and a AbstractListDataReader. But this is just the way I would do this. We need to discuss it.
Converter is in a separate class