Issue Details (XML | Word | Printable)

Key: EJB_SPEC-62
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: marina vatkina
Reporter: jrbauer
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
ejb-spec

EJB lite should not require support for pre-3.0 deployment descriptors

Created: 17/Sep/12 03:00 PM   Updated: 29/Oct/12 06:13 AM   Resolved: 25/Sep/12 09:48 PM
Component/s: None
Affects Version/s: 3.2
Fix Version/s: 3.2

Time Tracking:
Not Specified

Tags: clarification
Participants: jrbauer and marina vatkina


 Description  « Hide

Thinking more about the clarification in EJB_SPEC-61 (thanks, Marina, for adding that!) raised the question of whether it makes sense to require support for deployment descriptors prior to EJB 3.0 in EJB lite. EJB lite does not require entity beans, mdb's, or 2.x home/component view for session beans. Since there is no way to properly define an "EJB lite session bean" with a pre-EJB 3.0 descriptor and other bean types are not required, there seems to be no value in (or ability) to use a <=2.1 descriptor with EJB lite. Unless someone can think of a reason why a pre-EJB 3.0 descriptor could be used with EJB lite, section 17.0.1 (EJB 3.2, pd2) should be modified to state (or footnote) that only 3.0 and greater DDs are supported for EJB lite. We should also add this to section 16.1, on the deployment descriptor bullet and/or in the table.

nit - there are also a couple misspellings in 17.0.1 that should be fixed up - writen and specfication.



marina vatkina added a comment - 18/Sep/12 11:13 PM

Do you have any specific text in mind that you would like to see in a footnote?

(thanks for catching the typos)


jrbauer added a comment - 21/Sep/12 09:16 PM

Something like...

17.0.1 (pd-2)
Existing EJB 3.1 and earlier applications must be supported to run unchanged in EJB 3.2 containers. All EJB 3.2 implementations must support EJB 1.1, EJB 2.0, EJB 2.1, EJB 3.0, and EJB 3.1 deployment descriptors for applications written to earlier versions of the Enterprise JavaBeans specification.[x]

[x] Implementations providing only the EJB 3.2 lite subset are only required to support EJB 3.0 and EJB 3.1 deployment descriptors.

or..

Existing EJB 3.1 and earlier applications must be supported to run unchanged in EJB 3.2 containers. All full EJB 3.2 implementations must support EJB 1.1, EJB 2.0, EJB 2.1, EJB 3.0, and EJB 3.1 deployment descriptors for applications written to earlier versions of the Enterprise JavaBeans specification. All EJB 3.2 lite implementations are required to support EJB 3.0 and EJB 3.1 deployment descriptors.


marina vatkina added a comment - 25/Sep/12 09:48 PM

I wrote this (and fixed .0. in the section numbers ):

Full EJB 3.2 implementations must support EJB 1.1, EJB 2.0, EJB 2.1, EJB 3.0, and EJB 3.1 deployment descriptors for applications written to earlier versions of the Enterprise JavaBeans specification. EJB 3.2 Lite implementations must support EJB 3.0, and EJB 3.1 deployment descriptors for applications written to EJB 3.x versions of the Enterprise JavaBeans specification.