el-spec
  1. el-spec
  2. EL_SPEC-14

null string value is converted to ""

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Works as designed
    • Labels:
      None
    • Environment:

      glassfish 4.0, el 3.0

      Description

      null string from JSF is converted to empty string.
      I traced to code com.sun.el.lang.ELSupport 350. Should this decision be left to EL client?

        Activity

        Kim Haase added a comment -

        I believe this bug corresponds to https://java.net/jira/browse/JAVAEETUTORIAL-249. The zip file attached to that issue reproduces the problem on EE 7. I will attach another zip file to that issue to show that the problem is new in EL 3.0, because when the test example is run in an EE 6 environment, it runs correctly.

        kchung added a comment -

        EL 3.0 spec (1.23.2 Coerce A to String) clearly says

        If A is null: return ""

        So this is behaving according to the spec.


          People

          • Assignee:
            Unassigned
            Reporter:
            jasonzhang2002gmailcom
          • Votes:
            2 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: