el-spec
  1. el-spec
  2. EL_SPEC-20

Reduce source/target from 1.7 to 1.6

    Details

    • Type: Improvement Improvement
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Labels:
      None

      Description

      Currently the el api and impl are set to source/target 1.7

      However, there are no functional requirement or features of the 1.7 JRE used.

      The only current barrier is with tests which fail when set to 1.6. However, when skipping tests, el compiles quite fine.

      This has a transitive cost of imposing 1.7 on JSP also.

        Activity

        Hide
        rotty added a comment -

        See JSP-43

        Show
        rotty added a comment - See JSP-43
        Hide
        rotty added a comment -

        After further discussion with colleagues we realized there is no need for this.

        the issue can be resolved "won't fix"

        Show
        rotty added a comment - After further discussion with colleagues we realized there is no need for this. the issue can be resolved "won't fix"

          People

          • Assignee:
            Unassigned
            Reporter:
            rotty
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: