embedded-glassfish
  1. embedded-glassfish
  2. EMBEDDED_GLASSFISH-119

Embedded Glassfish 3.1-SNAPSHOT (b30+) can't handle Remote EJBs

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: current
    • Component/s: Other
    • Labels:
      None

      Description

      The EJBContainer implementation that is part of 3.1b30 and later has trouble with remote EJBs. A test case is attached.

        Activity

        Bhavanishankar added a comment -

        Modified testcase to use maven-embedded-glassfish-plugin.

        Bhavanishankar added a comment -

        Looks like EJBContainer.createEJBContainer API works only for local EJBs but not for remote EJBs. I confirmed it by running v2/appserv-tests/devtests/ejb/ejb31/embedded/remote test, that fails with the same exception as reported in this issue. Thats probably the reason why 'remote' test is not included in the ejb31/embedded/build.xml, hence it is not run as part of the complete test suite.

        Now, to be able to test remote EJBs with Embedded GlassFish, one should use the maven-embedded-glassfish-plugin.

        I have updated the testcase for the same and attached it here. It works fine. (All your EJBs remain the same, but only the deployment happens via maven glassfish plugin)

        If you wish, please raise a bug in glassfish project under 'ejb_container' component to fix EJBContainer.createContainer API for remote EJBs.

        Since I am giving an alternative way to test remote EJBs with the Embedded GlassFish, I am closing this issue.

        ljnelson added a comment -

        Um...OK, that's a workaround, I guess, but this test case works with Glassfish 3.0.1-b02, so I consider this to be a regression.

        Bhavanishankar added a comment -

        Hi, as I mentioned in my earlier comment:

        This seems to be a regression in EJB container. please raise a bug in glassfish project under 'ejb_container' component to fix EJBContainer.createContainer API for remote EJBs.

        ljnelson added a comment -

        This bug seems related or superseded by this: http://java.net/jira/browse/GLASSFISH-15775

        Briefly, none of the Glassfish APIs involving an embeddable EJB container support @Remote EJBs. My understanding was that at least the proprietary org.glassfish.embeddable APIs should support @Remote EJBs, and javax.ejb.embeddable.EJBContainer is under no obligation to do so.


          People

          • Assignee:
            Bhavanishankar
            Reporter:
            ljnelson
          • Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: