embedded-glassfish
  1. embedded-glassfish
  2. EMBEDDED_GLASSFISH-120

Deployer.getDeployedApplications() returns "Not yet implemented"

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: 3.1
    • Component/s: API
    • Labels:
      None

      Description

      http://embedded-glassfish.java.net/nonav/apidocs/org/glassfish/embeddable/Deployer.html#getDeployedApplications%28%29

      returns

      java.lang.UnsupportedOperationException: Not yet implemented
      at com.sun.enterprise.admin.cli.embeddable.DeployerImpl.getDeployedApplications(DeployerImpl.java:129)

      this needs to be implemented.

      Also, please check for other source code in http://embedded-glassfish.java.net/nonav/apidocs throwing this "UnsupportedOperationException: Not yet implemented" and ensure that there are no other exceptions of this "Not yet implemented" type.

        Activity

        Bhavanishankar added a comment -

        How bad is its impact? (Severity)
        > Severe

        Identify why the fix needs to occur now:

        • An in-your-face issue that will touch the majority of users

        How often does it happen? (Frequency)
        > Always

        How much effort is required to fix it? (Cost)
        > Fix available with me

        What is the risk of fixing it? (Risk)

        > No Risk (it is a separate API method implementation)

        Does a work around for the issue exist? Can the workaround be reasonably employed by the end user?

        > No workaround is available.

        If the issue is not fixed should the issue and its workaround (if applicable) be described in the Release Notes?

        > We can not release note it.

        Bhavanishankar added a comment -

        3_1-review

        Bhavanishankar added a comment -

        Fix will be available in b38.


          People

          • Assignee:
            Bhavanishankar
            Reporter:
            jbenoit
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: