Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: 3.1
    • Fix Version/s: None
    • Component/s: API
    • Labels:
      None

      Description

      In Junit integration test I'm trying to deploy an EAR application with one EJB JAR module onto embedded glassfish instance. In the module is sun-ejb-jar.xml for SGES2_1_1, but the "endpoint-address-uri" is ignored and the webservice is listening in another context. So I created the glassfish-ejb-jar.xml with the same settings - but it does not work either.

      Apr 13, 2011 2:42:49 PM com.sun.enterprise.deployment.archivist.Archivist readRuntimeDeploymentDescriptor
      WARNING: DPL8027: Ignore META-INF/sun-ejb-jar.xml in archive .../ear/target/glassfish/instanceroot/applications/my-1.1.0-SNAPSHOT/my-ejb_jar/, as GlassFish counterpart runtime xml META-INF/glassfish-ejb-jar.xml is present in the same archive.
      Apr 13, 2011 2:42:49 PM com.sun.enterprise.deployment.node.DeploymentDescriptorNode setElementValue
      WARNING: DPL8007: Unsupported deployment descriptors element debugging-enabled value true
      Apr 13, 2011 2:42:49 PM com.sun.enterprise.deployment.node.runtime.WebServiceEndpointRuntimeNode setElementValue
      SEVERE: DPL5041:Unknown port-component-name MyWS port, all sub elements will be ignored"
      Apr 13, 2011 2:42:49 PM com.sun.enterprise.deployment.node.DeploymentDescriptorNode setElementValue
      WARNING: DPL8007: Unsupported deployment descriptors element endpoint-address-uri value /webservice/MyWS
      Apr 13, 2011 2:42:49 PM com.sun.enterprise.deployment.node.DeploymentDescriptorNode setElementValue
      WARNING: DPL8007: Unsupported deployment descriptors element auth-method value BASIC
      Apr 13, 2011 2:42:49 PM com.sun.enterprise.deployment.node.DeploymentDescriptorNode setElementValue
      WARNING: DPL8007: Unsupported deployment descriptors element transport-guarantee value NONE

      ....

      INFO: WS00019: EJB Endpoint deployed
      my-1.1.0-SNAPSHOT listening at address at http://mymachine:8080/MyWS/MyWSBean

        Activity

        Hide
        dmatej added a comment - - edited

        Forget it ... maybe ...

        It was my fault - the problem was in port-component-name - if it is incorrect, I can see these tragic messages - I have only one desire - could these messages be more descriptive? It took nearly whole day to find where the problem is ... At first I thought that some settings are not supported and so I cannot use embedded glassfish at all.
        Finally I made it work perfectly as I wanted.

        Show
        dmatej added a comment - - edited Forget it ... maybe ... It was my fault - the problem was in port-component-name - if it is incorrect, I can see these tragic messages - I have only one desire - could these messages be more descriptive? It took nearly whole day to find where the problem is ... At first I thought that some settings are not supported and so I cannot use embedded glassfish at all. Finally I made it work perfectly as I wanted.

          People

          • Assignee:
            Bhavanishankar
            Reporter:
            dmatej
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: