Issue Details (XML | Word | Printable)

Key: FABAN-20
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Minor Minor
Assignee: yaominchen
Reporter: zhenyun
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
faban

master/bin/startup.sh has incorrect faban.war path

Created: 08/Dec/11 10:52 PM   Updated: 14/Dec/11 08:38 AM   Resolved: 14/Dec/11 08:38 AM
Component/s: None
Affects Version/s: None
Fix Version/s: None

Time Tracking:
Not Specified

Environment:

Solaris 11


Tags: faban master startup
Participants: yaominchen and zhenyun


 Description  « Hide

After deploying faban-kit.jar, the entire faban directory is created.
Under ~faban/master/bin there is startup.sh, which is used to start the faban master.
Running startup.sh, it complains that faban.war is not found.

root@pae-madrid-01:~# faban/master/bin/startup.sh
Starting Faban Server
java.io.FileNotFoundException: ../webapps/faban.war (No such file or directory)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(FileInputStream.java:128)
at java.io.FileInputStream.<init>(FileInputStream.java:87)
at sun.tools.jar.Main.run(Main.java:259)
at sun.tools.jar.Main.main(Main.java:1177)
Please point your browser to http://pae-madrid-01:9980/

The cause is that startup.sh has an incorrect faban.war path (../webapps/faban.war), it should be changed to ../faban.war.



yaominchen made changes - 09/Dec/11 01:21 AM
Field Original Value New Value
Assignee yaominchen [ yaominchen ]
yaominchen added a comment - 14/Dec/11 08:38 AM

Followed the steps in http://java.net/projects/faban/forums/faban-developers-forum/topics/30992-How-to-build-Faban-with-NetBeans to build faban-kit-121311.tar.gz. Unzip and untar the file to create the faban directory. The faban.war file is indeed under master/webapps.

~/www/nightly/faban/master/webapps$ ls
balancer faban.war fenxi.war ROOT

So it is the startup.sh issue.

  1. Since Faban uses root context, make sure it is unjarred before startup
    cd "$PRGDIR"/../webapps --> we are already inside webapps
  1. Avoid version conflicts - re-unjar faban.war before each start.
    rm -rf faban fenxi xanadu xanadu.war
    mkdir faban
    cd faban
    $JAVA_HOME/bin/jar xf ../webapps/faban.war --> the last parameter should be changed to ../faban.war

commit a259cb594f89ccef771fca49a24314abf5aa0763
faban-kit-121411.tar.gz


yaominchen made changes - 14/Dec/11 08:38 AM
Status Open [ 1 ] Resolved [ 5 ]
Resolution Fixed [ 1 ]