flamingo
  1. flamingo
  2. FLAMINGO-17

Focus ring on the wrong item in collapsed gallery (Substance LnF)

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Incomplete
    • Affects Version/s: 4.0
    • Fix Version/s: milestone 1
    • Component/s: ribbon
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      17

      Description

      (Sorry for submitting here but the substance-flamingo issue tracker hasn't got
      the required components)

      Under substance look and feel (i.e. from the demos at
      http://www.pushing-pixels.org/?p=500 ), when clicking on an item in the
      collapsed gallery view the keyboard focus ring (the dotted border) appears over
      the wrong item, generally the item to the right of the clicked item, though not
      always as can be seen when choosing an item from the expanded or non-first-line
      of the gallery.

      Haven't tested under other look and feels.

        Activity

        mattnathan added a comment -

        Created an attachment (id=5)
        Screen showing focus ring on item to right of just clicked item

        kirillcool added a comment -

        Moving to version 4.0.

        Couldn't reproduce on standalone toggle buttons (placed in the same group). Need
        to investigate further why this happens only in ribbon gallery component.

        mattnathan added a comment -

        I think I found another instance of this problem that reproduces under all look
        and feels. It manifests slightly differently but is probably the same problem.

        To reproduce:
        1) launch the ribbon demo
        2) open the styles gallery pop-up
        3) click on 'Style 3'
        4) click on 'Style 2' once the pop-up has been hidden (make sure you don't roll
        over the 'State 3' button when doing this)

        Note that the 'Style 3' command button still remains in the 'hover' state until
        you hover over that button again; even if you show the gallery pop-up again.

        kirillcool added a comment -

        The painting of focus ring has been removed from the command buttons. Closing
        this as INVALID since it is no longer relevant.

        Thanks
        Kirill


          People

          • Assignee:
            kirillcool
            Reporter:
            mattnathan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: