flamingo
  1. flamingo
  2. FLAMINGO-3

columns not being resorted on resize

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: 3.1
    • Fix Version/s: milestone 1
    • Component/s: common components
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      3

      Description

      I have a JIconPopupPanel and a JCommandButtonPanel with JCommandButton objects
      inside.

      I noticed that depending upon what parameters I give the JIconPopupPanel
      constructor I get 2 different behaviours, both fo which are flawed.

      Behaviour 1: It all works as expected however the actual area of the
      iconpopuppanel extends past what it contains resulting in a huge area of empty
      space underneath the last button group.

      I can fix behaviour 1 by changing my constructor to:

      icons = new JIconPopupPanel(panel, 0, 0);

      Which fixes behaviour 1 and all appears to work fine until the window is
      resized. Rather than reduce the number of columns or show a horizontal scroll
      bar the icon popup panel resizes and you can see that the contents have not
      resized. Half truncated icons are show where the button extends beyond the edge
      of the icon popup panel and beyond which lie the rest of the columns.

        Activity

        redstar added a comment -

        Created an attachment (id=1)
        A screenshot of the behaviour 1 bug, setting the second parameter of the constructor to a none zero value results in this

        redstar added a comment -

        hmm version 3.1 not 1.1, not sure why it wouldn't let me choose 3.1

        kirillcool added a comment -

        There have been major improvements in supporting resize on command button panel
        component (in addition to allowing column-first fill mode). Are you running
        under the latest 3.1dev drop?

        If so, and the problem still persists, please attach a small test app along with
        the scenario to reproduce the problem.

        Moving to newly added 3.1 version tag.

        Thanks
        Kirill

        kirillcool added a comment -

        Closing as INVALID since no response received for a test app. Feel free to
        reopen if this behavior is still present under the latest 3.1dev drop + a small
        test app to reproduce the scenario.

        Thanks
        Kirill


          People

          • Assignee:
            kirillcool
            Reporter:
            redstar
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: