flamingo
  1. flamingo
  2. FLAMINGO-30

Ribbon resize width smaller throws IllegalStateException

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.1
    • Fix Version/s: milestone 1
    • Component/s: ribbon
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      30

      Description

      If I resize the ribbon bar horizontally to make the ribbon as small as possible,
      I get an exception during layout of the ribbon because the actual 'collapse
      kind' does match the expected kind, and the available width is larger than the
      actual width. (see below)

      The actual ribbon renders OK as far as I can tell, so I think this exception
      looks like a debug print statement to me, and if so, the
      RibbonLayout.layoutContainer() method should probably just return and not throw
      the exception in a future release.

      java.lang.IllegalStateException: Available width of 'Report' under ICON was
      reported to be 56, but the actual collapse kind is HIGH_TO_LOW with width 42
      at
      org.jvnet.flamingo.ribbon.ui.BasicRibbonUI$RibbonLayout.layoutContainer(BasicRibbonUI.java:737)
      at java.awt.Container.layout(Container.java:1432)
      at java.awt.Container.doLayout(Container.java:1421)
      at java.awt.Container.validateTree(Container.java:1519)
      at java.awt.Container.validateTree(Container.java:1526)
      at java.awt.Container.validateTree(Container.java:1526)
      at java.awt.Container.validateTree(Container.java:1526)
      at java.awt.Container.validateTree(Container.java:1526)
      at java.awt.Container.validate(Container.java:1491)
      at java.awt.Window.dispatchEventImpl(Window.java:2438)
      at java.awt.Component.dispatchEvent(Component.java:4243)
      at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
      at
      com.lefthandnetworks.Hardware_API_GUI.MyEventQueue.dispatchEvent(MyEventQueue.java:193)
      at
      java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
      at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
      at
      java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
      at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)

        Activity

        kirillcool added a comment -

        The entire layout layer has been rewritten in version 4.0. Please try the latest
        4.0dev drop to see whether this issue has been addressed.

        Thanks
        Kirill

        ericscroger added a comment -

        Works fine in 4.0. I would recommend closing as WONTFIX since it's fixed in 4.0.

        kirillcool added a comment -

        Moving to 4.0 for verification and fixing.

        The entire layout layer has been rewritten to be more robust and flexible (see
        [1]). This exception is no longer happening (and i'm not sure if it's thrown at
        all). marking as WONTFIX.

        Thanks
        Kirill

        [1] http://www.pushing-pixels.org/?p=874

        kirillcool added a comment -

        Actually, WORKSFORME would be a better resolution (at least in my view). WONTFIX
        implies that it's either working as designed, and is not going to be fixed. But
        it was already fixed

        kirillcool added a comment -

        Marking as WORKSFORME for version 4.0.

        ericscroger added a comment -

        Your choice on the status. You can definitely reproduce the exception in the
        version 3.1 as stated, so I reckon you didn't test it there. After rereading
        the status options, I see that LATER is probably better for this scenario:

        LATER: The problem described is an issue which will not be fixed in this version
        of the product.

        kirillcool added a comment -

        Doesn't really matter. Since i don't have resources to support older versions,
        in my projects the bug reports are always moved to the latest dev branch to be
        tested there. In this case, while it fails under 3.1, that code base is no
        longer supported for bug fixes.

        Thanks
        Kirill


          People

          • Assignee:
            kirillcool
            Reporter:
            ericscroger
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: