flamingo
  1. flamingo
  2. FLAMINGO-34

Impossible to use ribbon without jribbonframe

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 4.0
    • Fix Version/s: milestone 1
    • Component/s: ribbon
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      34

      Description

      When using jribbon inside an application that does not derive from jribbonframe
      rendering of application menu throws an exception. This is due lines 119-121 in
      BasicRibbonApplicationMenuUI (in those lines it queries JRF for JRibbon).

      In my case: I have my jframe and changeable content in it. Impossible to use
      ribbon in the way specified (more likely: I'd rather use it my way, it being
      inside a panel).

      Workarounds tried: expand JRF in my main frame, override getribbon to return
      correct ribbon. FAILS DUE: private method initribbon (it adds extra ribbon to
      the north).

        Activity

        kirillcool added a comment -

        JRibbonFrame is the only supported way to have a ribbon with the full
        functionality. The JRibbon constructor is made public only for those
        applications that absolutely cannot use the JRibbonFrame. In such scenarios, the
        JRibbon functionality will only be partial - by design. This includes, among the
        rest, missing support for application menu button and key tips.

        Closing this as WONTFIX.

        Thanks
        Kirill


          People

          • Assignee:
            kirillcool
            Reporter:
            mustaukko
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: