flamingo
  1. flamingo
  2. FLAMINGO-49

IllegalStateException exception running the webstart

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.2
    • Fix Version/s: milestone 1
    • Component/s: ribbon
    • Labels:
      None
    • Environment:

      Operating System: Windows XP
      Platform: PC

    • Issuezilla Id:
      49

      Description

      JNLP JREDesc in Component ignored:
      https://substance.dev.java.net/webstart/substance-all.jnlp
      JNLP JREDesc in Component ignored:
      https://flamingo.dev.java.net/webstart/flamingo-all.jnlp
      Substance-Flamingo-BuildStamp: June 1, 2009 20:27:53 PDT
      Substance-BuildStamp: June 1, 2009 20:25:42 PDT
      Flamingo-BuildStamp: June 3, 2009 20:46:15 PDT
      Look-and-feel change from null to Metal
      Look-and-feel change from Metal to Substance Office Blue 2007
      Exception in thread "AWT-EventQueue-0" java.lang.IllegalStateException: Ribbon
      band 'Find (toggle)' has resize policy
      org.jvnet.flamingo.ribbon.resize.CoreRibbonResizePolicies$Mid2Low has pref width
      80 which is followed by resize policy
      org.jvnet.flamingo.ribbon.resize.IconRibbonBandResizePolicy with pref width 86
      at
      org.jvnet.flamingo.ribbon.AbstractRibbonBand.checkResizePoliciesConsistency(AbstractRibbonBand.java:432)
      at
      org.jvnet.flamingo.ribbon.AbstractRibbonBand.setRibbonTask(AbstractRibbonBand.java:537)
      at org.jvnet.flamingo.ribbon.RibbonTask.<init>(RibbonTask.java:90)
      at test.ribbon.BasicCheckRibbon.configureRibbon(BasicCheckRibbon.java:1037)
      at test.substance.ribbon.NewCheckRibbon.configureRibbon(NewCheckRibbon.java:60)
      at test.substance.ribbon.NewCheckRibbon$3.run(NewCheckRibbon.java:169)
      at java.awt.event.InvocationEvent.dispatch(Unknown Source)
      at java.awt.EventQueue.dispatchEvent(Unknown Source)
      at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
      at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
      at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
      at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
      at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
      at java.awt.EventDispatchThread.run(Unknown Source)

        Activity

        kirillcool added a comment -

        Are you running the WebStart on Windows XP like you specified in the issue report?

        Thanks
        Kirill

        johanpr added a comment -

        Yes - win XP with jdk 1.6 u 13

        kirillcool added a comment -

        Can't seem to reproduce it. Here is my console output:

        Java Web Start 1.6.0_10-rc
        Using JRE version 1.6.0_14 Java HotSpot(TM) Client VM

        --------------------------------------------------------

        Substance-Flamingo-BuildStamp: June 1, 2009 20:27:53 PDT
        Substance-BuildStamp: June 6, 2009 15:07:51 PDT
        Flamingo-BuildStamp: June 6, 2009 23:55:51 PDT
        Look-and-feel change from null to Metal
        Look-and-feel change from Metal to Substance Office Blue 2007

        You see that the Flamingo / Substance Flamingo build stamps are from June 6 -
        i've added support for small buttons in ribbon galleries, but nothing regarding
        the layout / resizing.

        Can you clean your WebStart cache and run the demo once again under the 6u14
        release?

        Thanks
        Kirill

        kirillcool added a comment -

        Can't reproduce under XP SP3 as well. Do you have any custom font settings, or
        custom DPI settings on your machine? Can you attach a screenshot of the main
        Substance test application from https://substance.dev.java.net/see.html ?

        Thanks
        Kirill

        johanpr added a comment -

        Hi Kirill - I re-tested today with the June 6 build - it worked perfectly.
        We can close this issue.

        kirillcool added a comment -

        Confirmed to be fixed.

        Thanks
        Kirill


          People

          • Assignee:
            kirillcool
            Reporter:
            johanpr
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: