flamingo
  1. flamingo
  2. FLAMINGO-52

BreadCrumbBar does not display html-markup consistently

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 4.1
    • Fix Version/s: milestone 1
    • Component/s: breadcrumb bar
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      52

      Description

      Whe are using the BreadcrumbBar as an alternative for our JTree navigation.
      In the JTree, we use HTML-Markup to style the TreeNodes.

      Now we would like to use the same markup inside BreadcumbBar.
      Unfortunately, this seems to work only within the DropDown, but not within the
      Breadcrumbs. The Breadcrumbs show the markup itself instead like
      "<html><body>MyText</body></html>".

      The reason for thi is in the Class BasicBreadcrumbParticleUI. This class
      inherits from BasicLabelUI and overwrites some methods.
      The method installListeners(..) lacks the call to
      "particle.addPropertyChangeListener(this);", while uninstallListener(..) should
      contain the call "particle.removePropertyChangeListener(this);".

      InstallComponents(..) should contain "BasicHTML.updateRenderer(particle,
      particle.getText());", while uninstallComponents(..) should contain
      "BasicHTML.updateRenderer(particle, "");"

      Sincerely
      Markus Schlegel

        Activity

        kirillcool added a comment -

        The breadcrumb bar does not support HTML by design. Current internal
        implementation is using BasicLabelUI but that will change in the future to use
        command buttons - and those do not and will not support HTML text.

        Marking as WONTFIX since supporting HTML is not planned for any Flamingo
        components, including both command buttons and breadcrumb bar.

        Thanks
        Kirill


          People

          • Assignee:
            kirillcool
            Reporter:
            schlm3
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: