flamingo
  1. flamingo
  2. FLAMINGO-58

Popup menu from secondary menu placement is incorrect

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.2
    • Fix Version/s: milestone 1
    • Component/s: ribbon
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      58

      Description

      If I create a secondary menu as CommandButtonKind.ACTION_AND_POPUP_MAIN_ACTION
      and register a PopupPanelCallback using the setPopupCallback() method, the
      popup menu is not displayed to the right of the secondary menu but is about 200
      pixels below the secondary menu - the x location seems to be correct. The
      placement of the popup menu is correct if I use CommandButtonKind.POPUP_ONLY or
      CommandButtonKind.ACTION_AND_POPUP_MAIN_POPUP.

        Activity

        kirillcool added a comment -

        Is this observed in the main ribbon test application? If not, i will need to see
        a small (<100 lines) test app that reproduces this behavior under the latest
        4.2RC drop.

        Thanks
        Kirill

        jhawthorne added a comment -

        I cannot reproduce this issue in the BasicCheckRibbon application with the
        formal release of 4.2. I will search out the differences between my
        application and the test application.

        kirillcool added a comment -

        I would imagine that a test app will contain one empty ribbon task, and the
        application menu that has only that specific menu entry that results in
        incorrect placement of the popup menu - all under the just released 4.2.

        Thanks
        Kirill

        kirillcool added a comment -

        This issue will be closed as WORKSFORME without a reproducible test app.

        Thanks
        Kirill

        kirillcool added a comment -

        No reproducible test case after five months. Closing.


          People

          • Assignee:
            kirillcool
            Reporter:
            jhawthorne
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: