flamingo
  1. flamingo
  2. FLAMINGO-65

KeyTip not visible in popup of a collapsed band

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Won't Fix
    • Affects Version/s: 4.1
    • Fix Version/s: milestone 1
    • Component/s: ribbon
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      65

      Description

      When a ribbon band collapses, a special KeyTip is used to
      open a popup with its content. This KeyTip can be set with
      setCollapsedStateKeyTip. That works fine. But in the popup,
      the KeyTips are not shown. They still work, but you have to
      guess them. This looks like a bug to me.

      You can reproduce this with the Ribbon test webstart. In
      "Page Layout" (P), the "Clipboard" has "Paste" (V). In
      normal state, pressing Alt,P,V works. When you resize the
      windows to a small size, where the "Clipboard" changes to
      collapsed state, you can see (ZC) for the "Clipboard". The
      popup opens, but no KeyTips are shown. But Alt+P+ZC+V works.

        Activity

        kirillcool added a comment -

        Key tips on components in popups are not supported by Flamingo ribbon. This is
        mainly due to the current implementation that paints the key tips in a special
        layer in the overall JRibbonFrame. The popups live outside the main frame, and
        would require special handling. Especially challenging is the case when the key
        tips are painted outside the popup bounds (as they do in Office 2007).

        Marking this as WONTFIX since i do not have resources to do this myself. You're
        more than welcome to explore how the current support can be extended to popup
        content.

        Thanks
        Kirill


          People

          • Assignee:
            kirillcool
            Reporter:
            dhennig
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: