flamingo
  1. flamingo
  2. FLAMINGO-7

SVG Icons AsyncLoadlistener waiting on completion for cached icons

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: 1.0
    • Fix Version/s: milestone 1
    • Component/s: common components
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      7

      Description

      If I create a SvgBatikResizableIcon and assign an AsynchronousLoadListener to
      it, the first time, the AsyncListener will call completed, and updateUI() will
      be called, however, if I supply the same, cached Icon instance to another
      Button, the call to completed will not occur. The issue is that if I want to
      wait for the Icon to be completed before setting it, there is no way to check
      if the Icon is already loaded.

      Would it be possible to add an isCompleted() method on the
      SvgBatikResizableIcon, so that you can check whether to add the
      AsynchronousLoadListener to the Icon, other wise the listener just hangs around
      forever, or immediatly call completed() on the listener

        Activity

        kirillcool added a comment -

        Is the isLoading() method not good enough for this purpose?

        Thanks
        Kirill

        kirillcool added a comment -

        Closing since no response received from the original poster on the isLoading()
        method.


          People

          • Assignee:
            kirillcool
            Reporter:
            calum
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: