flamingo
  1. flamingo
  2. FLAMINGO-70

Setting popup rich tooltip to null hides the action tooltip

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.0
    • Fix Version/s: milestone 1
    • Component/s: ribbon
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      70

      Description

      When setting the popup rich tooltip to null, commandbutton is unregistered from
      RichTooltipManager.
      Current implementation does not check if the commandbutton action rich tooltip
      is != null, it just unregisters the component.
      Expected behaviour is that modifing popup tooltip will not modify the action tooltip

      Current impl:
      this.popupRichTooltip = richTooltip;
      RichToolTipManager richToolTipManager = RichToolTipManager
      .sharedInstance();
      if (richTooltip != null)

      { richToolTipManager.registerComponent(this); }

      else

      { richToolTipManager.unregisterComponent(this); }
      Should be replaced with something like:
      this.popupRichTooltip = richTooltip;
      RichToolTipManager richToolTipManager = RichToolTipManager
      .sharedInstance();
      if (hasRichTooltip()) { // tests if the component has any tooltip to display richToolTipManager.registerComponent(this); } else { richToolTipManager.unregisterComponent(this); }

      Also the popupRichTooltip, and actionRichTooltip cant be obtained as they are
      private and there is no getters. They could be protected (to allow for example
      disabled tooltips)

      Krzysztof

        Activity

        Hide
        kirillcool added a comment -

        This issue should be fixed in the latest 5.0dev drop. If this still happens,
        please attach a small (<100 lines) test application that reproduces this
        behavior under the latest 5.0dev drop.

        The second part is more of an RFE - please do not mix two different issues in
        one bug report. If you want to discuss this, the forum is a better place -
        especially to describe what do you mean by the "disabled tooltips".

        Also, please do not reply to the automated e-mail and keep the discussion of the
        original bug in the bug tracker so that its history is not lost.

        Thanks
        Kirill

        Show
        kirillcool added a comment - This issue should be fixed in the latest 5.0dev drop. If this still happens, please attach a small (<100 lines) test application that reproduces this behavior under the latest 5.0dev drop. The second part is more of an RFE - please do not mix two different issues in one bug report. If you want to discuss this, the forum is a better place - especially to describe what do you mean by the "disabled tooltips". Also, please do not reply to the automated e-mail and keep the discussion of the original bug in the bug tracker so that its history is not lost. Thanks Kirill

          People

          • Assignee:
            kirillcool
            Reporter:
            krzych_nowak
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: