glassfish
  1. glassfish
  2. GLASSFISH-10039

[BLOCKING] appserver hang after upgrade

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Incomplete
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: upgrade_tool
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Sun

    • Issuezilla Id:
      10,039

      Description

      Sidebyside upgrade from v3 prelude to v3 nightly build 10/01/09 on linux

      Appserver hangs after upgrading to v3. See attached logs.

      Steps to reproduce:
      1) install v3 prelude, start domain1, start derby
      2) checkout v3 prelude quicklook test as followed:

      need to have subversion-1.6.5
      need to set environment variables JAVA_HOME, ANT_HOME, S1AS_HOME (glassfish
      location), PATH to point to ANT_HOME\bin, JAVA_HOME\bin,SVN_HOME\bin

      svn co https://svn.dev.java.net/svn/glassfish-svn/tags/glassfish-3.0-Prelude-
      b28c/tests
      cd <workspace>\tests\quicklook\classloader\hellojsf
      ant -Dglassfish.home=%S1AS_HOME% build deploy runtest

      3) stop domain1

      4) install v3 glassfish build 10/01/09 called latest-glassfishi.zip from
      http://download.java.net/glassfish/v3/promoted/

      latest-glassfish.zip 01-Oct-2009 14:09 74M

      1. pwd
        /usr/nga/v3/glassfishv3/glassfish
      2. bin/asadmin version
        Version string could not be obtained from Server [localhost:4848] for some reason.
        (Turn debugging on e.g. by setting AS_DEBUG=true in your environment, to see the
        details).
        Using locally retrieved version string from version class.
        Version = GlassFish v3.0-b66 (build 66)
        Command version executed successfully.

      5) invoke asupgrade tool from <v3 installation>/bin/asupgrade -c
      give source and target values

      6) start v3 domain1 — Server hangs

      1. server.log
        29 kB
        Bobby Bissett
      2. server.log
        14 kB
        1xpert
      3. server.log
        36 kB
        1xpert

        Activity

        Bobby Bissett added a comment -

        Created an attachment (id=3716)
        web app used in test. does not deploy directly into v3

        Bobby Bissett added a comment -

        Per eng meeting, am reassigning to look into class loading issue. Simplest way to reproduce: just deploy
        the hellojsf war file that is attached to this issue. If that app deploys, then the upgrade test should be
        fixed (feel free to assign it back to me to check.)

        kumara added a comment -

        -> Real user id of sahoo

        Sanjeeb Sahoo added a comment -

        The application (hellojsf.war) is invalid. Whoever has written the app needs to
        explain why they have added the following manifest entry:

        HK2-Import-Bundles org.glassfish.jsftemplating

        which is causing the deployment to fail because there is no bundle with symbolic
        name org.glassfish.jsftemplating; there is one by the name com.sun.jsftemplating.

        Without this manifest entry, the app runs fine.

        Bobby Bissett added a comment -

        Thanks for the info. Since this was a prelude test, maybe there was some prelude-specific functionality
        that was being tested. I removed that entry from the manifest and the test still runs fine against prelude
        however. I then upgraded and there were no problems – could upgrade, start up, and access web app. So
        I'm closing this as invalid due to a bug in the web app.


          People

          • Assignee:
            Bobby Bissett
            Reporter:
            1xpert
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: