glassfish
  1. glassfish
  2. GLASSFISH-10083

war with annotation that doesn't deploy

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: deployment
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      10,083

      Description

      this war should be deployable

      it's blank web.xml

      works on Tomcat

      http://localhost:8080/examples/1k.jpg

      1. server.log
        86 kB
        survivant

        Activity

        survivant added a comment -

        Created an attachment (id=3455)
        war with annotations

        survivant added a comment -

        Created an attachment (id=3456)
        error log

        Hong Zhang added a comment -

        Yes, empty web.xml is fine as long as the web components are annotated with
        component annotations.

        When I tried to reproduce the problem, I got following NoClassDefFoundError.

        #|2009-10-27T16:03:23.755-0400|SEVERE|glassfish|global|_ThreadID=23;_ThreadName=Thread-1;|Class
        [ com/sun/grizzly/http/webxml/schema/WebApp ] not found. Error while loading [
        class grizzly.AnnotationParser ]|#]

        [#|2009-10-27T16:03:23.755-0400|WARNING|glassfish|javax.enterprise.system.tools.deployment.org.glassfish.deployment.common|_ThreadID=23;_ThreadName=Thread-1;|Error
        in annotation processing: java.lang.NoClassDefFoundError:
        com/sun/grizzly/http/webxml/schema/WebApp|#]

        Are there any additional set up needed before I could deploy the app?

        survivant added a comment -

        oups.. sorry. Look like a package a file that need grizzly deployer to load..
        delete the file from the war file and deploy it again.

        it has to work

        Hong Zhang added a comment -

        which file I should delete? Can you upload the correct archive?

        survivant added a comment -

        Created an attachment (id=3641)
        war without grizzly dependencies

        Hong Zhang added a comment -

        I could deploy the app with no problem (there are a couple warnings in the
        server.log, but no exceptions at all). And I could access this url ok after I
        deployed the app:
        http://nmr.east.sun.com:8080/examples/1k.jpg

        Can you try to deploy the app with the latest v3 build, maybe the problem you
        faced earlier was already fixed?

        Hong Zhang added a comment -

        The user just verified the problem is fixed


          People

          • Assignee:
            Hong Zhang
            Reporter:
            survivant
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: